Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Installer upgrade is killing my battery - pls help

  1. #1
    Default Installer upgrade is killing my battery - pls help
    Hi all,

    I noticed this problem in the last few days but I wanted to make sure it was the Installer the problem.

    Running 1.1.3 unlocked, I have enjoyed pretty good battery life since I bought the phone for Xmas, so when the battery went flat it took me by surprise. The first time, I thought I left the music or perhaps the light on, but it happened again and again. The battery only last me 24 hours with no calls made and a few less than 5 sms, it used to last more than 48 hours unless I made some calls or used the internet.

    So, I knew I had not installed anything in the last couple of weeks other than updating the Installer to v3.1. So I installed SysInfo to see what was running..

    The list of processes running is:
    Sysinfo
    SCHelper
    MobilePhone
    mediaserverd
    notifyd
    ptpd
    update
    Syslogd
    lockdownd
    mDNSResponder
    iapd
    cron
    crashreporterd
    configd
    commcenter
    BTserver
    launchd
    kernel_task

    The problem is that I don't know if any of the processes should not be running. I noticed BTserver, I guess this is for the bluetooth, however, I use bossprefs to disable bluetooh, Edge and SSH.

    Since this information was not so useful I needed to investigate if I had upgraded something else and forgotten about it....

    So I logged in to my /Applications directory and did a ls -lt and just as I thought, the only change was the upgrade of Installer.

    drwxr-xr-x root wheel May 5 23:40 Installer.app
    drwxr-xr-x root admin Apr 25 11:44 Terminal.app
    drwxrwxr-x root admin Apr 24 13:13 BossPrefs.app
    drwxr-xr-x root admin Apr 24 13:11 Capture.app
    drwxr-xr-x root admin Apr 23 02:53 iMemory.app
    drwxr-xr-x root admin Apr 19 17:07 iCalls.app
    drwxr-xr-x root admin Apr 18 13:38 CameraPro.app
    drwxr-xr-x root admin Apr 16 12:39 FontSwap.app
    drwxrwxrwx root admin Apr 16 11:29 SMSD.app
    drwxr-xr-x root admin Apr 7 15:57 Restart.app
    drwxr-xr-x root admin Mar 29 18:56 PocketTouch.app
    drwxr-xr-x root admin Mar 27 20:03 Converter.app
    drwxrwxr-x root admin Mar 17 17:13 weTool.app
    drwxr-xr-x root admin Mar 10 12:05 Chess.app
    drwxr-xr-x root admin Mar 10 08:35 Tris.app
    drwxrwxr-x root admin Mar 9 14:16 Preferences.app
    drwxr-xr-x root admin Mar 7 09:51 Battery.app
    drwxr-xr-x root admin Mar 1 11:40 Funiculus.app
    drwxr-xr-x root admin Feb 25 12:16 weDict.app
    drwxr-xr-x root admin Feb 23 21:20 Sudoku.app
    drwxrwxr-x root admin Feb 20 12:19 MobileSMS.app
    drwxr-xr-x root admin Feb 18 13:00 iSolitaire.app
    drwxr-xr-x root admin Jan 30 18:44 BossTool.app
    drwxr-xr-x root admin Jan 29 10:10 LocateMe.app

    These are all the 3er party applications I have.


    Is anybody else experiencing this problem or perhaps somebody knows what could be wrong?


    Thanks in advance


    Rick

  2. #2
    Livin the iPhone Life Apple iPie's Avatar
    Join Date
    Mar 2008
    Location
    Switzerland
    Posts
    1,113
    Thanks
    142
    Thanked 152 Times in 129 Posts

    Hi! Why do you think that it is inslaller?
    It might be Wetools or smthing else... Installer NEVER does things,like that...

  3. #3
    Quote Originally Posted by Apple iPie View Post
    Hi! Why do you think that it is inslaller?
    It might be Wetools or smthing else... Installer NEVER does things,like that...

    Obviously, you did not read my post

    WeTools was installed back in March and I never noticed any problems, it was only in the last 10 days or so that I've had problems with the battery.


    Rick

  4. #4
    iPhone? More like MyPhone GADeputy's Avatar
    Join Date
    Mar 2008
    Location
    GA
    Posts
    135
    Thanks
    26
    Thanked 9 Times in 8 Posts

    I've noticed for the last 3 or 4 days my battery has been going dead way earlier than normal too. I have no idea what is causing it though since I load tons of stuff on my phone every day.

  5. #5
    Quote Originally Posted by GADeputy View Post
    I've noticed for the last 3 or 4 days my battery has been going dead way earlier than normal too. I have no idea what is causing it though since I load tons of stuff on my phone every day.
    If I were you I would delete the applications you installed since you notice your battery going flat early and see what happens.... unfortunately, I cannot delete Installer - just to rule it out ....

    In my case, there was nothing installed or upgraded, for at least 10 days, before I upgraded Installer so I think the problem is the installer

  6. #6
    Livin the iPhone Life
    Join Date
    Jan 2008
    Location
    sd
    Posts
    1,084
    Thanks
    8
    Thanked 99 Times in 79 Posts

    installer seems to continuesly run. when its open its jus running the spinning wheel. and wont even install anything for me. i always force quit it when i close it to hopefully fully end whatever its doing.

    pretty annoying to have something on my phone that don't work. let alone its the most important thing on here. im about to try cydia...
    1.1.1>1.1.2>1.1.4>2.0>2.1>2.2>3.1>3.1.2 blackra1n'd

    waitin on my white iphone 4

  7. #7
    Im having same problem i have firmware 1.1.4 and ise ilerberty first time to unlock then battery was dying so restored firmware and used ziphone still no good I aint got any apps on there except cydia and installer 3 small games and bossprefs etc

  8. #8
    Quote Originally Posted by magic_d View Post
    Im having same problem i have firmware 1.1.4 and ise ilerberty first time to unlock then battery was dying so restored firmware and used ziphone still no good I aint got any apps on there except cydia and installer 3 small games and bossprefs etc
    Did you have the battery problem before the Installer upgrade?

    Before the upgrade my phone was fine.

    Rick

  9. #9
    I think I'm having the same problem too, gonna try to downgrade my Installer, and see if that is in fact the problem.
    Apple iPhone 3Gs: redsn0w 4.1 (8B117)
    Modem FW: 5.13.04 Unlocked: Ultrasn0w
    Preferred Apps: Cydia, Winterboard, 1nstall0us, Orbit, and SBSettings
    Don't Start None, Won't Be None. Get On... Before Ya Get Spit On


  10. #10
    I can confirm that Installer is always running. My battery dies much faster also. The latest version of Installer is pretty buggy too. I've come across more hangups now then I ever did on my iPhone and I haven't restored my iPhone this much ever

  11. #11
    Downgrading helps the battery life, but I get alot of errors trying to download stuff.
    Apple iPhone 3Gs: redsn0w 4.1 (8B117)
    Modem FW: 5.13.04 Unlocked: Ultrasn0w
    Preferred Apps: Cydia, Winterboard, 1nstall0us, Orbit, and SBSettings
    Don't Start None, Won't Be None. Get On... Before Ya Get Spit On


  12. #12
    i assume cydia is the same, cydia comes with lot apps installed that i dont need used as core apps for it, im sure it must be cydia or installer draining battery life as i got nothing else running, i think it was better before..

  13. #13
    OP, I don't have a cron process running. Might want to look at UIctl to see what services are running there; I notice that sometimes they do not appear on sysinfo's list of processes.

    Also, the new terminal stays in the background. In stead of logging off (exit, ctl-d...), tap the screen, tap exit and hit return to kill all terminal sessions. As well, check to see if other games (iSolitare) and programs (iCalls) do this.

    I wonder if Capture and other screen shot utilities would not affect battery life.

    Just guessing...

  14. The Following User Says Thank You to mjohns For This Useful Post:

    rrsodl (2008-05-17)

  15. #14
    Quote Originally Posted by mjohns View Post
    OP, I don't have a cron process running. Might want to look at UIctl to see what services are running there; I notice that sometimes they do not appear on sysinfo's list of processes.

    Also, the new terminal stays in the background. In stead of logging off (exit, ctl-d...), tap the screen, tap exit and hit return to kill all terminal sessions. As well, check to see if other games (iSolitare) and programs (iCalls) do this.

    I wonder if Capture and other screen shot utilities would not affect battery life.

    Just guessing...
    Thanks for your input, useful info.... certainly something to think about. I'm thanking you for your help

    LK Th3Myth;

    How did you downgrade the installer?

    Thanks in advance

    Rick

  16. #15
    i'm getting low battery life too. but maybe it's that new intelliscreen app

  17. #16
    How is it possible to downgrade the installer?

  18. #17
    iPhone? More like MyPhone GADeputy's Avatar
    Join Date
    Mar 2008
    Location
    GA
    Posts
    135
    Thanks
    26
    Thanked 9 Times in 8 Posts

    I think I figured out my problem. One of the many apps that I recently loaded seems to always be running in the background even if I close it down. It's the Navizon GPS app. I checked with UIctl and there's a navizondeamon that's constantly running even when I don't have the Maps or Navizon apps running. I'm going to remove Navizon and see if that improves my battery life.

  19. #18
    Yeaaah I was saying something about this yesterday after my phone actually just locked up wasnt doing anything at all. Luckily it fried the harddrive and I got me a new iPhone from Apple. =) But yes I have all the same processes running as you do except I have a RemindMe (I think its for Kate), Springboard, and I dont have SCHelper. but yeah I have noticed battery drainage and alot more Installer lock ups or Failed to Download Packages too. and I'm running a brand new OTB 1.1.4 4g with ZiPhone JB. I use the mod that changes your battery bar at the top right corner to a percentage so that helps look at it better....or its really more of a countdown now...ha

  20. #19
    I still have a copy of 3.0 when it first came out, so I just threw that on the iphone. It helps with the battery life, but now I can't install anything, keep coming up with a Main Script Excution Error. Anyone know how to fix, it won't let me reinstall Installer.app, so I'm kinda of stuck, all my apps work, and I hate to do a restore at this point.
    Apple iPhone 3Gs: redsn0w 4.1 (8B117)
    Modem FW: 5.13.04 Unlocked: Ultrasn0w
    Preferred Apps: Cydia, Winterboard, 1nstall0us, Orbit, and SBSettings
    Don't Start None, Won't Be None. Get On... Before Ya Get Spit On


  21. #20
    Doesn't it offer you to update Installer when you refresh the sources? If not then I think the installer still thinks is v3.1 and PERHAPS the only way to avoid restore is to replace the files with the files from Installer 3.1

    In my case, I think I will have to wait until there is an Installer update.... or perhaps I bite the bullet and remove all the applications and see what happens....

    If I just knew what are the standard processes that run on the iphone I should be able to figure out what is causing the problem.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •