Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: I messed up my phone with iLiberty. Please helpp

  1. #1
    Default I messed up my phone with iLiberty. Please helpp
    Ok so my iphone was unlocked, jailbroken, on 1.1.3 firmware, bootloader 4.6, I then decided I wanted to downgrade to 1.1.2 again..being the noob that I am, I used iLiberty (w/o reading the guides) thinking I would be able to downgrade to 1.1.2, unlock, and jailbreak but after running the jailbreak and the bootloader on iLiberty, it upgraded my phone to 1.1.4, 04.04.05_G. I didn't want to be on 1.1.4 so I tried restoring back to 1.1.2. After I restored back to 1.1.1 and jailbroke it, I installed sub system and then I went to install the 1.1.2-1.1.3 g_unlock from installer to unlock it but it would not install. It said main script error. So I'm thinking it's not installing the unlock because my baseband changed to 04.04.04? How do i change it back to 04.03.14G? I really need to downgrade back to 1.1.2 and I have nooo idea what to do. Can someone please help?

  2. #2
    Main Script Execute Error, just comes down to permissions not being set on files for Installer.

    Its nothing to do with the Baseband.

    Did you restart the phone after Installer was installed?
    If that fails just restore back to 1.1.1 and try again.

  3. #3
    yeah i did restart the phone and i also tried restoring back to 1.1.1 like 3 times and came up with the script error again. How do i set permissions on files for installer?

  4. #4
    Thats strange alright. Okay so im not 100% up on this. I know its just an installer file permissons problem nothing more. I had the same problem when i upgraded to 1.1.4.

    Just to check. If you WinSCP into your phone using SSH check the what the permissions are set to on the installer folder. It should be 0755.

    Right easiest way

    Login to the phone using WinSCP. open the putty window and type the following commands

    cd /Applications
    chmod +s Installer.app/Installer
    chown -R root:wheel Installer.app

    and then

    chmod 4755 /Applications/Installer.app/Installer

    This should sort it out
    Last edited by davkav; 2008-04-25 at 12:12 PM. Reason: Automerged Doublepost

  5. #5
    Quote Originally Posted by davkav View Post
    Thats strange alright. Okay so im not 100% up on this. I know its just an installer file permissons problem nothing more. I had the same problem when i upgraded to 1.1.4.

    Just to check. If you WinSCP into your phone using SSH check the what the permissions are set to on the installer folder. It should be 0755.

    Right easiest way

    Login to the phone using WinSCP. open the putty window and type the following commands

    cd /Applications
    chmod +s Installer.app/Installer
    chown -R root:wheel Installer.app

    and then

    chmod 4755 /Applications/Installer.app/Installer

    This should sort it out
    Should i restore and jailbreak back to 1.1.1 and then do all of this stuff in WinSCP?

    I checked and it is set to 0755..still keep getting the main script execution error =( Do i need to check the box for set group, owner and permissions recursively?
    Last edited by candyg12l; 2008-04-26 at 03:24 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •