Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: iphone 3GS won't recognized by Itunes/not charging, possible logic board issue?

  1. #1
    Default iphone 3GS won't recognized by Itunes/not charging, possible logic board issue?
    I recently bought a 3GS that was on plug into Itunes/Emergency screen waiting to activate. The issue is when I plugged it into itunes, itunes won't detect it and it also not charging the phone. Thinking that the dock assembly was broken, I pulled the logic board and put it into my working 3GS phone and itunes also won't detect it. So look like it is a faulty logic board. I visually check the connector #4 (dock connector) and it doesn't look damaged at all. Water damaged logic board? The indicator on it is still white. Any suggestion to the issue or the logic board is death and I am screwed?

  2. #2
    Same problem. It took me forever to find a thread that was recent AND had the same problem as me. I have a jailbroken (via iPhone 3GS on 4.0.1 firmware (I'm pretty sure it's on a firmware that's not to far from the release of iOS4). iTunes is up-to-date and so are the drivers for my USB/firewire hub on my computer.

    My situation in the steps they happened:
    1. My iPhone didn't load/charge/play music in my car when it was connected via USB.
    2. Battery drains to about 4%. I tried connecting it to my computer, my brother's computer and his wall charger. I even tried a firewire charger from my 4th gen iPod. Tried using a respring app to restart my phone. I even shut it off via holding the sleep/wake button until the red slider showed.
    3. Went to hard reset the phone. It turned off and stayed blank. I connected it to my computer via USB and it stays blank. Blank like the screen doesn't even turn on. Because when it does you can see the color black(when in a well lit environment) and it emits a light when you're in a dark place(when in a dark environment). When I press the sleep button to turn it on, the phone shows the dead battery screen with the "you need to charge it" icons below the battery.
    4. Switched to the firewire cable and tried turning it on. This time it only shows the dead battery icon. I don't see the plug > lightning bolt icon.
    5. During my second hard reset/DFU mode attempt (still connected via firewire) the dead battery screen shows, blinks red, and before I can count to ten (I got to 7), it flashes white and shuts the screen down. I continue to counting to 10. Release the sleep/wake button and before I can count to 10 again (I only got to 3 this time) the dead battery screen (without the white icons underneath) comes up again. After blinking red it shuts the screen off.
    6. Continued to hold down the home button to no avail.

    My diagnosis: The dock connector or motherboard is pooped-up.

    My possible solution: I need to take it apart and replace the dock connector or change the battery.

    Other thoughts: I've tried restarting my computer while the iPhone was plugged, having iTunes on and off while trying to reset/recover/DFU and leaving it connected to try and charge it. I'm 21 months into my two-year contract with AT&T. I'm sure I have no warranty time left.

    What do you guys think? Did I hit the nail on the head? Is there a way to fix this WITHOUT opening it(via software I guess)?

  3. #3
    Default iphone 3gs dead
    Im very frustrated, i think my y iPhone 3gs went to dead mode. 3 days ago i tried to down graded so i could put the iPad baseband so i could unlock it. But i couldn't first it went to recovery mode and had so menu iTunes errors, then something happened and went to dfu mode and could never get out of it. and got stock initializing libpois0n. Now i cant even got the iPhone to being recognize by iTunes on mac and not even on windows. can someone help?

  4. #4
    My iPhone is a Part of Me
    Join Date
    Dec 2010
    Montreal, Quebec, Canada
    Thanked 30 Times in 30 Posts

    If it won't accept charge and iTunes won't recognize it then it's a dock connector assembly issue. If you replace the dock connector assembly and the issue persists it's an issue with your logicboard.
    If I helped you in any way, please click on the button!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts