Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Proximity Sensor/Earpiece problem after 3gs screen replacement

  1. #1
    Default Proximity Sensor/Earpiece problem after 3gs screen replacement
    Hey all
    After I replaced my 3gs screen, my earpiece and proximity sensor stopped working. I've tried to disconnect and reconnect the connector 3 and it hasn't worked. I'm scared to keep trying in fear of breaking the little white flap that holds the connector in place, bc I'd really be SOL then.

    What can I do?
    Thanks in advance.

  2. #2
    Make sure there is no rips in the ribbon and have you power cycled the phone? If your sure everything is plugged and you have done a power cycle try a restore and see if that resets it with the phone

  3. #3
    Thanks but after a reset and making sure none of the ribbons were torn I still have the problem. Not quite ready to restore though.

  4. #4
    Quote Originally Posted by anywherebuthere View Post
    Thanks but after a reset and making sure none of the ribbons were torn I still have the problem. Not quite ready to restore though.
    I am guess the ribbon is either damaged or not sync right which mean you need to restore

  5. #5
    iPhone? More like MyPhone krazy's Avatar
    Join Date
    Sep 2007
    Location
    Orange County, CA
    Posts
    108
    Thanks
    27
    Thanked 20 Times in 19 Posts

    I replied to your PM. Your ribbon could just be damaged. Even though it may not look like it is, it easily is. Shoot me an email.
    How to fix #3 CONNECTORS:
    http://hectordtruong.blogspot.com/

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •