Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Vibrate Switch Issue (iPhone 4)

  1. #1
    Default Vibrate Switch Issue (iPhone 4)
    Don't know what happened. It was working fine, switched the phone to vibrate before I went to bed last night. Woke up this morning...then went to switch it back and the switch is real loose; it doesn't vibrate when you flip it to the vibrate side. Is the switch hosed? Did something internally come apart? I'm thinking maybe something broke on the switch because of the fact that it's not a "firm" click anymore. It's a real loose feeling. Any input/advice?

    Thanks!

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Try taking it to a Apple Store and see what they say. They may give you a new one.

  3. #3
    Well I've done a white iPhone 4 swap, but what would cause it to just work and not work. That's what I don't get. I don't think the physical vibrate module is bad, but what would happen to cause the switch to get a "loose" feeling and just not have that click feeling anymore?

  4. #4
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Ok, so you have had it apart then. Probably something to do with how it was put back together. I havent gone that deep into taking apart a iPhone 4 so cant help much with that sorry.

  5. #5
    I am guessing the toogle part of the switch got broke some how its a mystery until you take it apart and find out for sure.

  6. #6
    Quote Originally Posted by x98car View Post
    Ok, so you have had it apart then. Probably something to do with how it was put back together. I havent gone that deep into taking apart a iPhone 4 so cant help much with that sorry.
    No problem bud; appreciate the response!

    Quote Originally Posted by westerman View Post
    I am guessing the toogle part of the switch got broke some how its a mystery until you take it apart and find out for sure.
    Yeah that's what I'm thinking...I think the toggle switch is just broken and I guess I'll just order one and put a new one in. If that doesn't fix the issue, then I'm putting all my OEM black parts in and taking it to Apple.

  7. #7
    Quote Originally Posted by Lefty126 View Post
    Well I've done a white iPhone 4 swap, but what would cause it to just work and not work. That's what I don't get. I don't think the physical vibrate module is bad, but what would happen to cause the switch to get a "loose" feeling and just not have that click feeling anymore?
    I recently did the same - Swapped my cracked black screen out for white and did a complete white conversion. Got it all back together last night and everything worked great...except the vibrate toggle isn't working at all.

    The phone still vibrates when I go into setting and turn it on and it will vibrate along with ringtones. However, I can't user the toggle to go into silent mode with vibrate.

    I'm taking it apart again and trying to see if something got misplaced or broken when I did the conversion. If you happen to find anything on your end let me know.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •