Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3gs speaker problem

  1. #1
    Default 3gs speaker problem
    i replaced the dock on my 3gs for my mic was not working, but when i turned on the iphone the message "this accessory is not optimized for iphone" showed up and the speaker doesn't work
    the only sound i can hear from it is from my voice memos and that's it...

    do you happen to have any suggestions??

  2. #2
    Quote Originally Posted by whookids View Post
    i replaced the dock on my 3gs for my mic was not working, but when i turned on the iphone the message "this accessory is not optimized for iphone" showed up and the speaker doesn't work
    the only sound i can hear from it is from my voice memos and that's it...

    do you happen to have any suggestions??
    Have u done a restore? I know sometimes with screens for example they will be white when u replace them unless you do a restore. Guessing its the same with the speaker the phone just needs to reccaliberate

  3. #3
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Make sure those ribbons are connected securely and correctly. My touch screen wouldn't work until I opened it back up and re-secured the connectors. One wasn't put on correctly, it was secure but wasn't on right.

  4. #4
    iPhone? More like MyPhone
    Join Date
    Nov 2010
    Location
    Indianapolis
    Posts
    292
    Thanks
    4
    Thanked 15 Times in 14 Posts

    SOmething is not hooked up right or the 3GS dock connector is bad..

    I only see that message when the dock connector is bad. Sometimes you will get faulty parts from ebay or amazon. I just came across a faulty dock connector today during a repair.

  5. #5
    i made a restore and still got that message and no sound through my speaker except from Voice Memos
    i fixed this issue by setting 644 permissions to "iapd" file...i don't know exactly what is that file for but my speaker now works the way it should

  6. #6
    iPhone? More like MyPhone
    Join Date
    Nov 2010
    Location
    Indianapolis
    Posts
    292
    Thanks
    4
    Thanked 15 Times in 14 Posts

    Quote Originally Posted by whookids View Post
    i made a restore and still got that message and no sound through my speaker except from Voice Memos
    i fixed this issue by setting 644 permissions to "iapd" file...i don't know exactly what is that file for but my speaker now works the way it should
    hhhmmm interesting.

    Where did you read this info at? for the fix.. I'd like to read it
    Last edited by iRepairIndy; 2010-11-11 at 02:57 AM.

  7. #7
    Quote Originally Posted by iRepairIndy View Post
    hhhmmm interesting.

    Where did you read this info at? for the fix.. I'd like to read it
    sorry for responding this late...
    google for iapd iphone or iapd accessory...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •