Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Is it teh digitizer or not?

  1. #1
    Green Apple iamubiquitous's Avatar
    Join Date
    Aug 2008
    Low Cal., it's SoCal.
    Thanked 3 Times in 3 Posts

    Default Is it teh digitizer or not?
    My 2g got loan'd (tl;dr) and came back with a portion of the lower screen not responding. I got a quote fore the digitizer on 2g' for the factory part: $148.00 But I seem to get it to work every now and then, of course not enough to be of any use when I need it to.
    Here's the deal: screen shot 1 is doodle app showing dead spot. Screen2 is showing it working BUT only on a random fast wipe. So do any of you have any idea wtf this is and/or how to fix? Any suggestions are welcome Thanks in advance!
    Attached Thumbnails Attached Thumbnails -img_0137.png   -img_0138.png  
    Rules one and two ALWAYS in effect.

  2. #2
    iPhone? More like MyPhone Excel Wiz's Avatar
    Join Date
    Mar 2010
    Santa Barbara, CA
    Thanked 7 Times in 7 Posts

    That is strange. Save your money and get the new iPhone when it come out.

    MacBook Pro 15" Core i7|4GB|500GB|HiRes
    iPhone 4 16GB
    iPhone 3G 8GB

  3. #3
    Yes its the digitizer and the price you where quoted is about right.

  4. #4
    I am facing EXACT same problem with my iPhone 2G, that exact same row is not responding and due to this i cant dial zero on the dialer

    Is there any app which change the location of iphone dialer or maybe make it rotate?

  5. #5
    What's Jailbreak?
    Join Date
    May 2010
    Thanked 2 Times in 2 Posts

    I have a similar problem, but the area is on top, the marked area.
    It's an iPod Touch 2G (MC model if it does matter)

    Swipes works great, but no taps. Can even swipe slowly to switch pages, but still no working taps.

    I replaced a broken screen+digitizer, and for about 3 weeks it worked great. Then this area started to act out, but after a restore of 3.1.2 it worked again, and now when JailBreakMe was released it started to act out again, and I've tried with 3.1.2 again but doesn't work, so I can rule out any software fault, even thou it was my first thought after the first incident. So do you have any ideas of what is causing this?

    Bought the digitizer (includes glass and faceplate) at

    Sorry for kinda "hijacking" this thread, but in my understanding it's the same problem, just different areas of the screen.

    EDIT: Looked up when I bought it to see if there was any warranty left. And there was. Sent them a mail just now.
    Attached Thumbnails Attached Thumbnails -ipod-touch2.png  
    Last edited by PentaMedia; 2010-08-03 at 10:34 PM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts