Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Ipod Touch Won't Turn On!

  1. #1
    Default Ipod Touch Won't Turn On!
    Hello everyone, this is my first post.

    I have a 32 Gig First Generation Ipod Touch running a 3.1.2 Firmware that is Jailbroken via Blackra1n

    The Problem is that I can't get it to turn on,

    I plug it into the computer, and my computer doesn't pick it up, it reads nothing. and the Apple Logo comes for about 3 seconds, and at the last second it lights up a bit brighter for a little less than half a second.

    And yes I tried holding down the power and home button multiple times, resulting in the same result.

    I don't care if I lose all my data, all I care right now is to get it to work.

    If you have any advice, please let me know. Thank you.

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Austin, TX
    Thanked 1,681 Times in 1,159 Posts

    When holding down the power and home buttons are you holding them for about 20 seconds? This should force the iPod into recovery mode. If this doesn't work then you'll need to learn how to put the iPod into DFU mode (look it up).

  3. #3
    I holded it to the point where my thumb started hurting (Exaggeration LOL)

    Like for about a minute

    I tried DFU Mode as well, but none of the computers I own are not picking it up, as if like there is nothing plugged in.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts