Results 1 to 18 of 18

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: connect refused after 1.1.1 jailbreak/ssh install

  1. #1
    Default connect refused after 1.1.1 jailbreak/ssh install
    I have done the 1.1.1 jailbreak successfully, verified with the getfile fstab check that ive got rw access. I followed the steps to install ssh (even noticed the fileref: 0 and made sure i did the putfile again). Ive rebooted several times. But every time I try to ssh into the phone I get connection refused. I was able to ssh prior to the upgrade so I know its not a network issue. Ive also tried the old and new passwords (dottie, alpine) with no luck. Anyone else seeing this problem?

    -Scott

  2. #2
    Green Apple
    Join Date
    Oct 2007
    Location
    Columbia, SC
    Posts
    79
    Thanks
    9
    Thanked 3 Times in 3 Posts

    i'm not exactly getting that. but i keep getting operation timed out when i try to input my ip address

  3. #3
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    make sure you are using SCP, not SFTP or FTP

  4. #4
    im getting this too!
    i jailbreakede my 1.1 iphone, and everything went fine, but winscp says connection failed or soemthing to that matter. ive never really used ssh before, as this is my first time, so i may be doing something wrong. i know the name is root, and the pass is dottie, or alpine, port should be on 22, nd the host is my ip adress that shows up in my wifi settings. at least i think this is true.

    someone please help me! i cant live without my 3rd party apps, and i need the bsd substystem anyway!!

  5. #5
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    Make sure you are using SCP, not SFTP or FTP.

    Also, try the trouble-shooting part of the guide.

  6. #6
    iPhone? More like MyPhone
    Join Date
    Jul 2007
    Location
    Austin, TX
    Posts
    200
    Thanks
    9
    Thanked 13 Times in 13 Posts

    Quote Originally Posted by unclear View Post
    Make sure you are using SCP, not SFTP or FTP.

    Also, try the trouble-shooting part of the guide.
    yeah, i updated the wiki with the troubleshooting section and it has fixed most people's problems! give it a try (its at the very bottom of the ssh page)

  7. #7
    well i'm having the same issue and m getting really pissed i had a 1.0.2 modded and and know what it up with ssh. All my files are there, and they installed during all the steps, and i tried that troubleshooting install of the plist and still no connection.. WTF!!!! anyone with any other fixes?

  8. #8
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    try sshify again. this time reboot twice at phase 3.. wait a full minute after each time the homescreen loads.

    did you verify 'rw' in fstab?

    also, make sure you get a fileref: 1 for EVERY file.
    Last edited by unclear; 2007-10-14 at 04:01 AM. Reason: Automerged Doublepost

  9. #9
    I got the "RW", but however I didn't wait a full minute between reboots..i'll try again.. this sucks.. and in step 4 i usually don't get the "1" in the last file, but I install it manually as stated in instructions
    Last edited by Fox; 2007-10-14 at 04:14 AM.

  10. #10
    I dont even know what steps to take now... I did everything suggested in the wiki discussion thread and this thread. I might have tried more than 10 times, but im not sure what is going wrong.

  11. #11
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    what settings are you trying to connect with?

  12. #12
    the ip for host
    root/alpine port 22
    scp


    i went back to 1.02 because i thought i might have messed up on the jailbreak... then as i am back on 1.1.1 and am trying again, i am getting the same connection refused error

  13. #13
    Well I finally got it to connect, by using nate's jailbreak... I installed all the files according to the guide, but then when all done, my phone now has no springboard and where the carrier logo would be it says ipod? WTF!

  14. #14
    I tried this as well but have had no luck, made sure I have full write access with fstab.
    Also made sure I used putfile the last file that the .bat missed as well as the one suggested in the troubleshooting section.

    WinSCP setting
    ip:22
    root/alpine
    SCP

    Error: connection refused


    Edit:
    In the meantime I downgraded to 1.0.2. My phone was unlocked with IPSF so even with the 1.1.1 baseband I can still make calls.

    I guess I'll wait for that point and click solution that is rumoured to come out around October 20th? Unless someone here come up with a solution :P
    Last edited by strang; 2007-10-14 at 10:25 AM.

  15. #15
    yeah, im having the same problem here too..

    connection refused

    i have tried the process 4 times and still no luck... and the 4 times i have tried was jailbreak 1.1 and did SSH and error then, restore to 1.1 then downgrade to 1.0.2 then jailbreak again to 1.1 and still no luck... help!!

  16. #16
    My iPhone is a Part of Me Sidetalker's Avatar
    Join Date
    Sep 2007
    Location
    York, PA
    Posts
    902
    Thanks
    7
    Thanked 400 Times in 122 Posts

    I HAVE THE ANSWER!!!

    This took me forever and a half to find.

    Download Nate True's sshkit from the link on this website (under step one)

    unzip that file to your desktop or wherever is best for you.

    then go to your ssh folder (the one that you have been running sshify-windows.bat out of) and copy the iphoneinterface.exe file from that folder to your new sshkit folder. now run sshify-windows.bat out of your sshkit folder

    (ps. if it asks you to overwrite iphoneinterface when copying over say yes)

    follow the rest of the instructions to the letter and at the end do the troubleshooting step.

    BAM! ssh-ness

  17. The Following User Says Thank You to Sidetalker For This Useful Post:

    T800 (2007-10-15)

  18. #17
    Quote Originally Posted by unclear View Post
    make sure you are using SCP, not SFTP or FTP
    What is SCP? I have three options in CyberDuck: FTP, FTP-SSL and sFTP. How do I choose SCP in CyberDuck?

  19. #18
    iPhone? More like MyPhone
    Join Date
    Jul 2007
    Location
    Austin, TX
    Posts
    200
    Thanks
    9
    Thanked 13 Times in 13 Posts

    Quote Originally Posted by Sidetalker View Post
    I HAVE THE ANSWER!!!

    This took me forever and a half to find.

    Download Nate True's sshkit from the link on this website (under step one)

    unzip that file to your desktop or wherever is best for you.

    then go to your ssh folder (the one that you have been running sshify-windows.bat out of) and copy the iphoneinterface.exe file from that folder to your new sshkit folder. now run sshify-windows.bat out of your sshkit folder

    (ps. if it asks you to overwrite iphoneinterface when copying over say yes)

    follow the rest of the instructions to the letter and at the end do the troubleshooting step.

    BAM! ssh-ness
    lol... i put that in the wiki in the troubleshooting section like 2 or 3 weeks ago

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •