Results 1 to 17 of 17

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: how to downgrade iphone 4, 4.3.5, itunes errors :S help *

  1. #1
    Default how to downgrade iphone 4, 4.3.5, itunes errors :S help *
    well im following everything and nothing working changing hosts files and errors still . if some1 can team viewer me wud be great, tried for ages
    im running 64bit windows 7 if that helps . thanks will be appreciated

  2. #2
    Any other details? iTunes version? SHSH blobs saved? Version you're trying to restore to? What errors you're getting?

  3. The Following User Says Thank You to docmagoo2 For This Useful Post:

    marcon (2011-09-24)

  4. #3
    Quote Originally Posted by docmagoo2 View Post
    Any other details? iTunes version? SHSH blobs saved? Version you're trying to restore to? What errors you're getting?
    latest itunes. im not sure how to check shsh blobs saved or owt . im kinda new really . i want to downgrade to v4.3.3*** . i get error 20 . and 3000 and sommat not sure any ideas ?
    Last edited by marcon; 2011-09-24 at 11:36 AM.

  5. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    If you have not saved your blob or you have not jailbroken your device before then you wouldn't have any blob, thus you cannot downgrade.
    To check for blob :
    Plug bootable iPhone
    Run Tiny umbrella
    Advance Tab : request shsh from cydia , click savE shsh
    Under General Tab : you should see it if you have any.

  6. #5
    I'm running into this problem too-been at it for over 8 hours now and no luck. I'm actually on an iPad1 but getting these same errors and posting here due to similarity of the issue & the fact that the iphone forums seem to get a lot more responses. Trying to go from 4.3.5 to 4.3.3. Had been on 4.2.1 & hit an unfixable boot loop last night when an app store update hung & I tried to power off & turn back on. Tiny Umbrella & Fix Recovery failed repeatedly for me 4+ times each on two different craptastic PCs running XP.

    details:
    I have saved SHSH on my computer and in Cydia.

    I downloaded the 4.3.3 ipsw from a RedmondPie link-I believe it's stock.

    I have tried shift/restore to 4.3.3 from both DFU & recovery mode.

    I get a different error every time. I've seen error 20, 1601 & 1604 and 3xxx something. Never the same one twice. Have tried different USB ports & cables.

    I'm at the end of my rope! Really hoping someone can help. I use it for everything and the massive amount of Cydia tweaks I install means frequent reboots or resprings as well as the not-rare spontaneous reboot due to just too much JB sh*t installed at once so a tethered JB just is not really an option for me. I'm a paid subscriber to Grooveshark and have probably spent over $50 this year on Cydia stuff like PhotoAlbums+, RichHTML for gmail, RetinaPad, ActionMenu, ScreenDimmer etc etc so I've got a fair chunk of change in software tweaks I'd like to access too.

    Anyone who can help me get this epic #%## of a downgrade to work, will have my eternal thanks & I'm even willing to gift a few iTunes apps or Cydia tweaks. I have a POS Thinkpad and Dell desktop so I only use them for JB or restore...my iphone & iPad are my "computer."

    Thanks in advance to anyone with advice, fingers crossed for a solution.

    -Jenn

  7. #6
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    How did you set the options in TU ?

    Under general tab , what blobs do you have ?

    You can post a pic of TU under advance tab here.
    Last edited by iYeow; 2011-09-24 at 08:44 PM.

  8. #7
    Thanks for responding...I've tried (this is for the prior Fix Recovery attempts and restores) both having "set hosts to Cydia on exit" checked and unchecked. I've also tried it with everything but "overwrite blobs" checked and unchecked.  Anything I can think of... I have iPad1 & iPhone4 blobs showing for everything from 3.2.2 (version it shipped with) on up for the iPad and 4.3.1 on up for the iphone4 (a replacement this spring due to camera jamming so it came w/4.3.1).

    Hi again, sorry I missed your mention of posting a pic the first time I read your reply. Here is a pic of the current TU settings.
    Attached Thumbnails Attached Thumbnails -imageuploadedbymodmyi1316890423.224088.jpg  
    Last edited by glttrgrl; 2011-09-24 at 08:53 PM.

  9. #8
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    When dowmgrading, did you put your iPhone into dfu mode and start TSS server?

  10. #9
    The first couple times I tried it in recovery but after reading about the 16xx errors I started trying DFU mode. Now when I start TU I get this msg which I've never seen before.

    Also, sometimes in these attempts I'm noticing that either TU or iTunes will spontaneously quit immediately (not freeze, just disappear & quit instantly leaving no error or notice behind). My computer just lags for minutes sometimes...no Windows CD so I'm stuck with what I have there.

    I was able to restore to a workable 4.3.5 (which I first did this morning after earlier failed attempts to go straight from boot/recovery loop DFU on the corrupted 4.2.1 to 4.3.3 and not up to 4.3.5). So I know that I can get a clean restore to factory on 4.3.5 but anything else has become a nightmare. 

    Sorry if my last reply didn't mention it directly but yes the last 3-4 times I put into DFU mode, start iTunes (or start iTunes first & then go DFU, tried both) and then start TU & the TSS server. It allows the shift-restore & I select the 4.3.3 ipsw, then it goes through the whole thing & kicks out a different iTunes error at the end & I'm back at a clean device still on 4.3.5.
    Attached Thumbnails Attached Thumbnails -imageuploadedbymodmyi1316891872.515227.jpg  
    Last edited by glttrgrl; 2011-09-24 at 09:26 PM.

  11. #10
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You seem to have a problem with your computer, TU wants to quit, you need to fix that.

  12. #11
    I'm trying for 4.3.3 and not 4.2.1 or 4.3.4 because after all this I am so hoping that I can simply then Slide to Jailbreak! Although I did JB my iPhone with custom Redsnow before so if I need to do something more elaborate I can. But historically I've run into errors (never this bad) even on stock restores to current FW on both devices because my old computers both suck so much, so I don't think it's going to improve much if I try to go to 4.2.1 or 4.3.4 etc.

    Do resprings require you to also boot tethered via Redsnow on 4.3.5? If I absolutely can do nothing else I will try that but I have a feeling I will end up with it stuck booting all day bc I can't get to my home computer if it crashes.

  13. #12
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Have you tried putting into pwned dfu and restore to custom firmware.

  14. #13
    Haha yeah, I have many problems with my computer! In the same boat as many in this economy; no $$$ for a new one (especially since it's kind of become that annoying box I boot up when something goes wrong with my iPad or iphone & that's about it). Without the reinstall CD my Windows is kind of borderline. I'm not savvy with registry editing but it's been a while since I rebooted so I'll at least try that. My brother has a new laptop so I could see if I could try that sometime soon. I had to get rid of my cable to offset gas prices (long commute) so my iPad is really my tv, Netflix/movies, computer & audiobook/ebook device. I know some ppl view it as a luxury but mine was a gift & it's pretty much my sole entertainment center these days.

    Thanks again for your patience & your help; much appreciated.

    I haven't tried PWNED DFU/custom firmware. Was thinking that may be an option but I don't know as much about that. I've JB both with GP & LR (and Spirit/web for 4.0) but have only used that method once so I'm a lot less familiar with the details of how to do it. Do you mean creating custom FW or downloading it? Sorry if that's a dumb question, only done it once.

    Would def try it-do you have a link to the best place that explains how? Obv I can google but there are so many shady fake JB site & blog links that I'm scared of messing up my computer even more from malware on those. Thanks again.

    Still figuring out how the MMI app threads things...I've JB many times, just meant I've only done it w/custom FW once. 
    Last edited by glttrgrl; 2011-09-24 at 09:49 PM.

  15. #14
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Try a different pc first because you need TSS server running for verification of your blob for the fw you are restoring

  16. #15
    Thanks; will give that a try. This is another sorta dumb newb-to-downgrading question: how, if possible, can I get those blobs onto another computer?

    -Saved blobs with SHSHit from Cydia & emailed them to myself so I can dl them onto any computer. In theory? But I did that under a diff user login on my laptop (tried just saving them from email to desktop) & TU didn't seem to see them bc that wasn't the user that originally ran TU.

    Under my main login (that I used back when I originally plugged it in & clicked Save SHSH in TU, they show up.)

    So if I use a different computer, and I'm not currently JB and on 4.3.5, how do I get TU to realize that the blobs are both DL onto the computer & saved in Cydia? I don't understand how to "import" them I guess?

    Also before I try this on a new computer, do you think I should try using Redsnow to JB 4.3.5? Or is there a way to use Redsnow to handle the whole 4.3.3 downgrade? I saw something about the new version being able to add saved blobs to FW, but I can't find any step by step on how to do that. I spent a fair amount of time today looking for info on that but most of what I found was highlights that assumed a little more knowledge than I have for the custom FW process or downgrade. In the past I've been lucky that my few epic corruption crash/restores happened when I could simply upgrade/set up as new and then JB on current firmware, so downgrading is really throwing me for a loop for troubleshooting or alternate methods like custom FW.

    Thanks again,

    Jenn

    Just answered part of my own question here - I guess I really don't know how to use TU. I thought that clicking save SHSH would only save the current version if you weren't JB, didn't realize it could pull them for a device not re-JB yet. I thought you needed to have Cydia installed on the device already. Anyway, learning.  Now I have blobs showing on a diff computer.
    Last edited by glttrgrl; 2011-09-25 at 05:54 AM.

  17. #16
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You didn't have to jailbreak to save shsh blob, so you are learning. Under general of TU , what blobs do you have ?

    Redsnow is a jailbreak tool, it doesn't downgrade firmware.

    I noticed you have windows 64 bits, when using redsnow, set compatibility to xp sp2 and affinity to one so your redsnow won’t hang at loading Ramdisk or crashes
    Last edited by iYeow; 2011-09-25 at 06:27 AM.

  18. #17
    Thanks again SO MUCH for your help here & in other threads. Just posted under "fixed my downgrade" here w/a brief explanation of how I was creating my own problems by not really understanding how TU works. I love the JB community & how many awesome tools & tweaks there are, but I realize most of it is unpaid for-donation stuff like TU. Therefore I don't expect reams of documentation or support for this kind of stuff.  But it can lead to confusion ie like I thought I understood totally how to do it even after reading the site, the ReadMe, RedmondPie & asking here but I was still doing it wrong.

    Thanks also for the Redsnow tip-my next project is trying to JB 4.2.1 on my old 3G that I gave to my brother as an iPod. The power button was broken & now fell out entirely so I'll need to use that for it I think. That adventure can wait for another weekend! 

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •