Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone 3gs jailbroken -> upgrading to 4.3 not eligible

  1. #1
    Default iphone 3gs jailbroken -> upgrading to 4.3 not eligible
    Hi, I am trying to upgrade 3gs to 4.3 and preserve the baseband. I am using Pwnage to custom build 4.3 firmware, but after that every time I try to restore it with itunes, it says "not eligible".

    I tried with 4.2.2, 4.3.1, 4.3.3

    Right now, the firmware is 3.1.3 with the newer bootrom (Model: MC*****)

    Neither of them were successful. Please help. I could not find any info about it in the net, and I read that apple still sign the 4.3.3 for 3gs

    P.S. I also checked the host file for gs.apple.com but I do not have any entries there

    Thanks

  2. #2
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by titombg View Post
    Hi, I am trying to upgrade 3gs to 4.3 and preserve the baseband. I am using Pwnage to custom build 4.3 firmware, but after that every time I try to restore it with itunes, it says "not eligible".

    I tried with 4.2.2, 4.3.1, 4.3.3

    Right now, the firmware is 3.1.3 with the newer bootrom (Model: MC*****)

    Neither of them were successful. Please help. I could not find any info about it in the net, and I read that apple still sign the 4.3.3 for 3gs

    P.S. I also checked the host file for gs.apple.com but I do not have any entries there

    Thanks
    A few things:

    1) Model number (MB/MC) is not a factor in determining the bootrom for the 3GS. Date of manufacture (as determined by the serial number) is. Bootrom is not an issue for all firmwares numbered 4.3.3 and lower.

    2) Apple is no longer signing 4.3.3 for the 3GS. The only public firmwares being signed are 4.3.5 and possibly 4.1.

    Grab TinyUmbrella (The Firmware Umbrella - TinyUmbrella), run it with your 3GS connected, and see what blobs it returns. With that information, make a custom firmware that matches a set of blobs you have, and go from there.

  3. #3
    Thank you, very much.

    I think there are for 4.1. I will try it and write the result here.

    Regards

    Update:

    After I tried couple of times, it was still showing 'not eligible', but after that I stopped the tinyUmbrella function "set hosts to cydia" and tried again. This time it was some progress, started to show me error 1600, but after a thorough check in google, I installed iReb and upgraded successfully.

    Mission accomplished

    Thank you for the support.
    Last edited by titombg; 2011-09-20 at 06:36 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •