Page 1 of 2 12 LastLast
Results 1 to 20 of 30

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Omg, iPhone 3G stuck in DFU mode? :( heeellpp. or recovery loop?

  1. #1
    Unhappy Omg, iPhone 3G stuck in DFU mode? :( heeellpp. or recovery loop?
    Hi. Aaahh this is a nightmare! It is stuck on Recovery Mode Loop.

    First of all, I have an iPhone 3G 4.0.2, 05.13.04 and I wanted to upgrade the version to 4.1 because my iPhone is soo laggy and slow. I heard it is way faster If i have 4.1 installed. I also want to keep my baseband. I have saved my shsh blobs in TU before I did all this.

    I followed the guide here Jailbreak iOS 4.1 on iPhone 3GS New Bootrom with Sn0wbreeze 2.0.1 [Custom Firmware Windows] | Redmond Pie

    I got to Step 9.

    I tried using sn0wbreeze 2.1 with a custom .ipsw 4.1 , once the restore was complete , the phone didnt restart after waiting 45 minutes! I turned it off and on again and all I see the sn0wbreeze logo. When connected to itunes it says it is in 'Recovery Mode', i tried to restore it by holding SHIFT + clicking Restore and chose the 4.1 cfw I created using sn0wbreeze. I got error 1603 in iTunes. I think it in in Recovery Loop? Because every few minutes , the screen would flash and blink and show the snowflake logo again. It does nothing... I have been searching 'iphone stuck in dfu mode' on this site and read over 20 posts for 2 hours and I still have no clue what to do!! Do I have to using iReb and put in pwn dfu?

    Someone help me please because I am getting a headache. Thankss.

    Edit: THANK YOU SOO SO MUCH ANNIE! [: YOU ARE THE BEST. [Problem Solved]
    Last edited by katastrophic; 2011-08-28 at 12:57 AM.

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Hit upgrade to upgrade to 4.2.1. Then use Redsn0w to jb as normal. You don't need to unlock, do you?

  3. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-27)

  4. #3
    Where do i hit upgrade? In iTunes? I want to upgrade to 4.1 though or any other firmware that doesn't make my iPhone slow.
    I have T-mobile so I will be needing it Unlocked.

  5. #4
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    4.2.1 is fine, if you wanted 4.1 in the first place it's the same thing. If you really want speed and best performance, you should be downgrading to 3.1.3 if anything. iOS 4 is no place for an iPhone 3G to be. And don't hit upgrade if you're needing an unlock. Let me know if you wanna go down to 3.1.3 and I can help you. If not, I can still give you instructions on upgrading to 4.2.1 without losing your unlock.

  6. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-27)

  7. #5
    First of all I need to know if the 4.2.1 is faster than the 3.1.3. Because some apps won't install and they require iOS4+ And I am not sure which is worth it. I think I am going to downgrade to 3.1.3.
    And If I install 3.1.3, will I be able to update the version it if a new version comes out in the future w/o upgrading my baseband?

  8. #6
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    3.1.3 is most optimal for an iPhone 3G. That's why I said iOS 4 is not a place where that device should be.

    The iPhone 3G stops at 4.2.1. There will be no more new fw versions for your device.

    Well let me know what you want to do. I kept my iPhone 3G on 3.1.3 even with 4.1 out before I sold it. Apps, if they're an issue that's too large to sacrifice, then upgrade to 4.2.1. Not a problem like 4.0.2 is, much better than 4.0.2, I just don't suggest it bc of my personal experiences.

    To be perfectly honest, I wouldn't even own an iPhone 3G at this point. I'd upgrade to a 3GS bc it runs beautifully on 4.2.1 and 4.3.3, that and it'll receive firmware updates. It'll stop at some point but right now isn't that time. But that's just me
    Last edited by i.Annie; 2011-08-27 at 08:24 PM.

  9. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-27)

  10. #7
    Ooh okay I see what you mean. Wow, I didn't know that! I learned something new ^__^ (:
    Okay I have decided to downgrade to 3.1.3 then. There is not much apps for me to install.
    But do I need to have the shsh blobs in TU? Cause I don't think I have it.
    Last edited by katastrophic; 2011-08-27 at 08:37 PM.

  11. #8
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    No you don't. For an iPhone 3G, Apple continues to sign 3.1.x. You don't need blobs. It's a very simple procedure. Open iTunes, hold shift, click restore, select 3.1.3 and let it restore. You'll likely get error 1015, it's an okay error, just open TU and hit "exit recovery" (not fix recovery) and you'll be sent to the emergency call screen. Then jailbreak it with redsn0w 0.9.4 (you'll need to download as well the 3.1.2 ipsw along with the 3.1.3, you'll restore to 3.1.3 but use 3.1.2 in redsn0w) as normal. Unlock with ultrasn0w in Cydia.

    And yes, this process will allow you to still unlock without the use of custom firmware because you are on 4.0.2, that baseband is unlockable and can't be downgraded along with the 3.1.3 fw version. So don't worry about anything else, just follow the above steps and you're good to go

    And there, you've learned more new things

  12. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-27)

  13. #9
    Yaay (: I am waiting for redsn0w and 3.1.2 to finish downloading and I will try it. I'll return back to you when I have tried the procedures! Thaankk You <3 Hope it works!

    Edit: Woo hooo I see the pineapple right now and it's loading .. *crosses fingers* I hope this will be a successful jb. Hehehe.
    Last edited by katastrophic; 2011-08-27 at 10:32 PM.

  14. #10
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Alright, good luck If you get stumped with something unexpected, let me know.

  15. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-27)

  16. #11
    I have followed your instructions very carefully and I finally restored on iTunes with with no problems! I did recieved 1015 error and I exited Recovery on TU. I JB it on redsn0w using 3.1.2 ipsw.

    I entered repo666.ultrasn0w.com into Cydia, and I got an error! O:

    It reads:
    http://apt.modmyi.com
    Failed to stat - stat (2 No such file or directory)

    There is an 'Okay' button below it and i pressed it but nothing happens. It just stays on that pop up error message.

    Now I see 4 Essential Upgrades. I can select Upgrade Essential, Complete Upgrade, or Ignore (Temporary. I don't know which one to choose?

    Oh noes D: Thaankss.
    Last edited by katastrophic; 2011-08-27 at 10:52 PM.

  17. #12
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Did you makes sure to go to "Changes" and update everything that needs to be updated first in Cydia?

  18. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-27)

  19. #13
    No I haven't, xD so should I click on Complete Upgrade and try It again? Thanks so much! So far I am doing great I thought my iPhone was bricked when I couldn't get out of Recovery Loop Mode but thanks to you, you saved my life! You are my hero (:
    -
    Edit: Right now I see Updating Sources at the top and the bar for Downloading Packages is full with a black screen o.O So nothing is loading.

    I am a bit impatient so I just turned off the phone and turned it back on again. And went back on to Cydia , now I'm installing the Essential Upgrades.. and It's working!! Woooohooooo~ <3
    Last edited by katastrophic; 2011-08-27 at 11:06 PM.

  20. #14
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Ok so ... nothing is loading? Well just give it 15 minutes and see if it progresses. If it doesn't, do a hard reset and go back into Cydia to do the "essential updates" only. Sometimes complete upgrades jam up. Then when you at least complete the essential updates you can install the repo to install ultrasn0w.

  21. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-27)

  22. #15
    When i entered in repo666.ultrasn0w.com do i have to add the "/' at the end of .com? I just read this in a forum. Because I didn't put the dash, I didn't know that.
    I installed ultrasn0w and it is rebooting, i just see a loading screen, the black screen has this spinning thing going around clockwise.
    It has been 26 mins! should i Power off and ON again? ):
    Last edited by katastrophic; 2011-08-27 at 11:35 PM.

  23. #16
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Ok I'm not understanding, so you did the essential upgrades already, right? And then you successfully added the repo, then you installed Ultrasn0w, am I following correctly? And now you've rebooted and it is just constantly on the black screen with the spinning wheel?

    It shouldn't take that long. Do a hard reset and turn it on, see if Ultrasn0w was successfully installed.

  24. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-27)

  25. #17
    Yes, I installed Essential Upgrades already. It is still rebooting right now. Ok I'll do the hard reset.

    Edit: I checked Cydia and I see ultrasn0w checked marked. I just popped in my Tmobile SIM, and it is Searching for my Carrier... right now.
    I just googled why there was still No Service. So.. Problem Fixed! I had to Disable 3G in Network.

    Oh my gosh Annie, You are like a goddess (: I owe you a cookie or something! Well thank you so much for helping me through my iPhone nightmares! Heheh. You are so kind ! I really appreciate your hardwork. Yaayy, I am now a happy person ;D -hi five-
    Last edited by katastrophic; 2011-08-27 at 11:55 PM.

  26. #18
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Yes that would've been my next advice, if you have no service, turn 3G off. If you have no data, turn data roaming on

    I think I want more than a cookie, I'll need like an entire cheesecake or something. Lol ok well I'm glad you got it all resolved, and have fun!

  27. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-29)

  28. #19
    Okay! (: How about a chocolate chip cookie, a cheesecake, and a thank-you letter? x) Thanks again my hero! Yaaayyyyyyyy [:
    Cheers. Have a nice day.

  29. #20
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Your success is my success See you around.

  30. The Following User Says Thank You to i.Annie For This Useful Post:

    katastrophic (2011-08-28)

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •