Page 1 of 2 12 LastLast
Results 1 to 20 of 38

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 DFU Mode loop 4.3.3 not your average DFU loop

  1. #1
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    Default iPhone 4 DFU Mode loop 4.3.3 not your average DFU loop
    I appologize for the lengthy read....I just wanted to be as thorough as possible. I am not a noob at this so this is really kicking my ***. I can solve most issues with jailbreaking downgrading and unlocks, but damn this DFU mode is a *****.


    I just bought an iPhone 4 on August 6, 2011. I am currently still using my iPhone 3gs until i get the Gevey unlock sim i ordered off ebay. (hopefully mid this coming week). Could'nt pass up a practically brand new iPhone 4 for 400 bucks, anyways...

    The iPhone 4 came with 4.3.3 firmware on it baseband 04.10.01.

    Synced it with my iTunes but some things were acting screwy since it was a used iPhone already jailbroken i decided to do a restore. It had shsh blobs saved on Cydia 4.3.3, 4.3.4 and 4.3.5. So i knew i could just stay at 4.3.3. So i put it in pwned DFU mode with pwnagetool, used TinyUmbrella's TSS Server and Restored multiple times with 1013 error and kicking straight back into DFU mode this whole time mind you. After combing the internet's iDevice forums i finally came across one that told me to check the UPDATE BASEBAND option in tinyumbrella. I had seen that option under advanced before after going into that window about a 10 different times changing crap.
    As this is my first iPhone 4 i was not too sure what the latest baseband was so i did some research and found out that it was ok for me check that as the baseband has not changed from 4.3.3-4.3.5 just the jailbreak has. So i checked it. BAM was able to get itunes to restore without the 1013 error.

    But now i was still stuck in DFU Mode loop. not recovery loop, that is one thing i have found is a lot of these forums were talking about recovery mode loop (connect to itunes icon) which i never even got once. Which did not help my case.

    So i tried to use FIXrecovery43 the file not the one in Tiny umbrella (that one doesnt do crap but get stuck at the greenpois0n menu on my iphone). And it goes through its whole process like its gonna work and nothing right back into DFU mode again. I must have done this at least 10 different times. Every time back into dfu mode.

    I tried installing cydia with Redsn0w which went through the whole jailbreak process a couple times, but right back into DFU mode, and 2 other times i tried this it stuck on the running pineapple Activating Bundles (i think thats what it was) either way whenever it was finished it would eventually go back to DFU mode.

    Got sick of that so i tried boot tethered for now on redsn0w and what do you know it booted in just fine and now my iphone works. But i have to treat it like a tethered jailbreak but a little different, this one just goes back into DFU mode if i reboot or shut it off. Its really strange and quite annoying. Automatic DFU mode makes running redsn0w a piece of cake. But still i know it should not be doing this.

    Oh forgot to mention i before i figured out the 1013 error i updated to 4.3.5 just to make sure it would update (cuz i had 4.3.3 blobs saved, i not worried and i wanted to make sure if i needed to i could always just update and be able to sue my new iphone 4) and it worked just fine with an official apple update. Was able to downgrade back to 4.3.3 without any itunes error but guess what my good old friend DFU mode.

    So its not any software issue, my firmware is just fine and runs great as of right now. its still syncing and i restored from NEW iPhone.

    As of right now, just DFU Boot loop if i reboot it or shut it down and just use it like a tethered jailbreak, but there has to be a solution for this. Unless an untethered jailbreak comes out for 4.3.5 i am just gonna be using Redsn0w to boot it up.

    If anyone has any insight or would like me to elaborate more about something, i am all ears. Sorry for the long post but i have literally been working on this all day and i still did not explain everything i did to a T.

    Thanks in advance.
    Last edited by vantheman169; 2011-08-08 at 06:01 AM.

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    What is your bootrom version of your iPhone 4 ? Mine is iBoot 574.4

  3. #3
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    574.4 also.

    Now its doing some really screwy ****...i am gonna restore it again...ughhh

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Lol, you said if you restore to 4.3.5, then you have no problem booting up without a jailbreak ,correct .

  5. #5
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    ok now i believe something due to hardware is screwing up. My screen is black, its restoring right now in itunes but the screen still black, no progress bar, no nothing. And just before i posted this i heard it make the battery noise because its was connected to my Macbook pro, but nothing on the screen. So i knew it was at the lockscreen, but i couldnt see crap.


    EDIT..Got the got the connect to Itunes logo so now it is in recovery mode for the first time today....am i glad to see that other than DFU mode, lol.

    Update: restoring to 4.3.5 in itunes and i have a progress bar on my iphone. I probably need to mess with my host files if iTunes errors out.
    Last edited by vantheman169; 2011-08-08 at 06:24 AM.

  6. #6
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Wondering if your shsh is corrupted !

    After you have restored successfully to 4.3.5, put your iPhone into Normal dfu and restore to 4.3.3 again , see what will happen.

    You know how to do a normal dfu , right?
    Last edited by iYeow; 2011-08-08 at 06:28 AM.

  7. The Following User Says Thank You to iYeow For This Useful Post:

    vantheman169 (2011-08-09)

  8. #7
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    you mean hold the Power button and home button for 10 seconds then release the power button and continue holding the home button till itunes says its in restore mode? If thats what you mean, then yes.

    As of right now i am restored to 4.3.5 at the activate screen as i dont have my gevey sim card unlock yet.

    Quote Originally Posted by iYeow View Post
    Wondering if your shsh is corrupted !

    After you have restored successfully to 4.3.5, put your iPhone into Normal dfu and restore to 4.3.3 again , see what will happen.

    You know how to do a normal dfu , right?
    Do you want me to use tinyumbrella?

    UPDATE/EDIT: I failed to mention the fact that when i finally got it restored to 4.3.3 it was with a Custom FW 4.3.3 made with Pwnagetool. My bad, i know that Custom FW is important info sorry.

    UPDATE: Trying to restore right now to 4.3.3 stock ipsw with tinyumbrella tss server running and iPhone 4 in regular DFU mode.

    UPDATE: I keep getting Error 1600 now. I only used to get this before when i wasnt in PWNED DFU.
    Last edited by vantheman169; 2011-08-08 at 06:48 AM.

  9. The Following User Says Thank You to vantheman169 For This Useful Post:

    3zoooz (2011-08-09)

  10. #8
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You shouldn't get error 1600, I suspect your Mac is giving you all this problem , do your restore on a pc

  11. #9
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    I dunno, i put it into PWNED DFU mode and its restoring right now. We will see what happens. This is to Stock 4.3.3 IPSW btw.

  12. #10
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    When I restore to 4.3.3 ,not a downgrade . I start tss server , hosts file set to cydia, iPhone 4 bb update , checked. It will restore to emergency screen and gets activated without a problem.
    Though one time I had to do it twice

  13. #11
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    hmm no kidding? what if i tried this on 2 different macs....i dont have a PC and i doubt running VM will be of any help.

    but see i am dowgrading from 4.3.5 so technically i need to be in Pwned DFU mode right?

    Update: Restored from 4.3.5 to 4.3.3 successfully with iTunes but kicked into DFU mode right away. Trying to boot tethered now...it worked lets see how long it stays on and not in DFU mode. I dont know what to do.

    UPDATE AGAIN: Ya this tethered boot with Redsn0w is not an option, once i unplug it from a power source it kicks into dfu mode after about 10 seconds.
    Last edited by vantheman169; 2011-08-08 at 07:02 AM.

  14. #12
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    It is possible Mac is giving you this problem , I do this on my Win 7 ultimate and never once boot up into dfu.

  15. #13
    My iPhone is a Part of Me xtacy's Avatar
    Join Date
    May 2011
    Location
    Mumbai
    Posts
    980
    Thanks
    1
    Thanked 93 Times in 92 Posts

    ^ if u r getting stuck in dfu BUT can boot tethered it would be ur shsh blobs.. Delete current blobs .. Save shsh Again. Try another Ipsw :-)

  16. The Following User Says Thank You to xtacy For This Useful Post:

    vantheman169 (2011-08-09)

  17. #14
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by vantheman169 View Post
    I dunno, i put it into PWNED DFU mode and its restoring right now. We will see what happens. This is to Stock 4.3.3 IPSW btw.
    I only use pwned dfu if I want to restore to custom firmware

  18. #15
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    Hmm strange just got a new one

    Unknown error (9) <---wtf

    Also got a (20) when trying to restore from recovery mode after it gave me the (9) error it went into recovery mode....restoring in pwned DFU mode again now to 4.3.3 with everything on TU checked except for set hosts to cydia on exit
    Last edited by vantheman169; 2011-08-08 at 07:41 AM.

  19. #16
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    iYeow .... Is this a similar issue Simon worked on which was solved by removing the battery to force a full reset? A drastic step sure, but wondering ....

  20. #17
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    No, this is different issue from the one you are talking about. The member can restore to latest firmware without problem.

  21. #18
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    Ok i fixed it!!! It must have been corrupted iSHSH blobs from cydia here is what i did since everything i tried was booting back into DFU mode.

    Upgraded to 4.3.5, used redsn0w beta to jailbreak with 4.3.4 IPSW. Jailbroke it, booted tethered. Installed SHSHIT from cydia and downloaded my 4.3.3 SHSH Blobs and emailed them to myself. Put them in my TinyUmbrella shsh folder and restored like normal with Itunes as i have been doing (pwned dfu mode, using TSS server) and holy hell! It works!

    I am now on 4.3.3 untethered, no DFU mode. Thank you iSHSHit. I could have lived with a tethered JB as i know it would not be forever, but untethered is much better.

    Thanks for the tip Xtacy

    and

    Thanks for all the help iYeow <--- was right the whole time corrupted SHSH blobs. +100000
    Last edited by vantheman169; 2011-08-09 at 06:02 AM.

  22. #19
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    Good job. Did you first try to get new SHSH blobs with Tiny Umbrella?

  23. #20
    My iPhone is a Part of Me vantheman169's Avatar
    Join Date
    Jul 2009
    Location
    Outter Space
    Posts
    888
    Thanks
    87
    Thanked 114 Times in 75 Posts

    Ya I tried but TU said it was not able to get 4.3.3 for some reason even tho Cydia had them on file. I am just glad I am back to 4.3.3 without DFU lol. I am glad I knew about iSHSHit but I had to get it first and then i just looked up how to jailbreak 4.3.5 and saw that redsn0w could do a tethered JB on it.
    Last edited by vantheman169; 2011-08-09 at 05:57 AM.

  24. The Following User Says Thank You to vantheman169 For This Useful Post:

    Mes (2011-08-09)

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •