Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: No 4.3 firmware offered for iPhone-4 by iTunes 10.4 - What the ..... ?

  1. #1
    Default No 4.3 firmware offered for iPhone-4 by iTunes 10.4 - What the ..... ?
    After upgrading iTunes to 10.4, I was expecting to be offered an upgrade (for my iPhone-4) to 4.34 or 4.35 ... but it's offering 4.2 (no further digits supplied).

    What the heck's going on ?

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    SOunds like a bug. It wont let you actually restore to 4.2.1 though. Not without SHSH anyway.

  3. #3
    Quote Originally Posted by Simon View Post
    SOunds like a bug. It wont let you actually restore to 4.2.1 though. Not without SHSH anyway.
    I'm currently on 4.01 (JB'n).
    Does it have to upgrade via 4.2 or something ?
    Is it likely to flash a 4.3x FW in spite of the 4.2 shown ?
    I'll try it on another machine.

    I won't be upgrading unless the new FW is JB'able.
    What's the current FW on offer .... 4.35 ?

    Jailbreakmatrix doesn't show iPhone-4 FW beyond 4.33.
    Hopefully, that's because that's the current FW - which I can JB at JBme.com.

  4. #4
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    4.3.5 is the firmware it will want to put you to. Currently there is only a tethered jailbreak for that.

  5. The Following User Says Thank You to Simon For This Useful Post:

    iPhoneThereforeIAm (2011-08-03)

  6. #5
    My iPhone is a Part of Me xtacy's Avatar
    Join Date
    May 2011
    Location
    Mumbai
    Posts
    980
    Thanks
    1
    Thanked 93 Times in 92 Posts

    U should update to 4.2.1 preserving ur bb :-)
    Use sn0wbreeze for a cfw.
    Ofcourse u will need shsh blobs

  7. #6
    Quote Originally Posted by xtacy View Post
    U should update to 4.2.1 preserving ur bb :-)
    Use sn0wbreeze for a cfw.
    Ofcourse u will need shsh blobs
    If I had updated to 4.21, I'd still be on it (no reason to downgrade).
    But obviously Apple has the whip hand these days - and patches JB exploits within weeks, making the upgrade window for JB's ever shorter and the unJB'able periods in between longer and longer.

    My advice to folk is to upgrade, JB and SHSH as soon as the JB's released - even though it's a ton of work to reconfigure.
    I know configuring my iPhone the way I need it takes an entire day.

    Someone could make a SERIOUS amount of money by writing a system imaging app that allows restoration with a few clicks.
    I know I'd be happy to pay for it.
    Last edited by iPhoneThereforeIAm; 2011-08-04 at 11:02 AM.

  8. #7
    Quote Originally Posted by iPhoneThereforeIAm View Post
    If I had updated to 4.21, I'd still be on it (no reason to downgrade).
    But obviously Apple has the whip hand these days - and patches JB exploits within weeks, making the upgrade window for JB's ever shorter and the unJB'able periods in between longer and longer.

    My advice to folk is to upgrade, JB and SHSH as soon as the JB's released - even though it's a ton of work to reconfigure.
    I know configuring my iPhone the way I need it takes an entire day.

    Someone could make a SERIOUS amount of money by writing a system imaging app that allows restoration with a few clicks.
    I know I'd be happy to pay for it.
    Have you tried PKGbackup?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •