Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Downgrading iPhone4 from 4.3.5

  1. #1
    Default Downgrading iPhone4 from 4.3.5
    Hi,
    I need some help with downgrading, please

    1. Does my phone have to be jailbroken to be able to donwgrade it?

    2. Is it possible to downgrade my phone fro 4.3.5 back to 4.2.1 (that is the latest version of software that Cydia had a copy of SHSH file saved for my phone) and then update it to 4.3.3 (so I can have my phone jailbroken untethered) ?

    Something went wrong when I was doing a few things so I had to restore factory settings and therefore update to the latest software through iTunes

    Any help will be greatly appreciated!!

  2. #2
    My iPhone is a Part of Me xtacy's Avatar
    Join Date
    May 2011
    Location
    Mumbai
    Posts
    980
    Thanks
    1
    Thanked 93 Times in 92 Posts

    Hmmm.. Cydia homepage is cached. It sometimes does not show shsh even if it has it. And no. If there are no shsh for 4.3.3 you can't go to that firmware.
    I would recommend 4.2.1 though .
    Download tiny umbrella.
    Save shsh. If Cydia has 4.3.3 it will fetch it for you..

    Download the 4.2.1 ipsw
    Start TSS server in tiny umbrella.
    Shift+restore in iTunes .
    It will give you 1013 error.

    Download fixrecovery from tinyumbrella blog.
    Run it.
    Jb using greenpois0n.
    Done.

  3. #3
    Thanks heaps, I'll try that now!
    Also before I do any of those, do I need to jailbrake the 4.3.5 software?

  4. #4
    My iPhone is a Part of Me xtacy's Avatar
    Join Date
    May 2011
    Location
    Mumbai
    Posts
    980
    Thanks
    1
    Thanked 93 Times in 92 Posts

    No :-)

  5. #5
    Great! thanks!
    And just to mkae it super clear for me=) After ive restored my phone to 4.2.1 i cannot manually upgrade it only to 4.3.3, instead of all the way up to 4.3.5?

    Print screen from tinyumbrella

    -tushsh.jpg

    Does this mean i can downgrade to 4.3.3?
    Attached Thumbnails Attached Thumbnails -tushsh.png  
    Last edited by Persik; 2011-07-27 at 01:59 PM.

  6. #6
    My iPhone is a Part of Me xtacy's Avatar
    Join Date
    May 2011
    Location
    Mumbai
    Posts
    980
    Thanks
    1
    Thanked 93 Times in 92 Posts

    U can seeing that u have blobs for 4.3.3
    Just use 4.3.3 instead of 4.2.1 and use redsn0w to jb..
    I prefer 4.2.1 though..

  7. #7
    Great!
    I did figure it was possible, but just wanted to check to be 100% sure, so i don't stuff up my phone again!
    Thank you so much for your help!!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •