Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Unlock/JB iPhone 3G 4.2.1 BB 05.15.04 help

  1. #1
    Default Unlock/JB iPhone 3G 4.2.1 BB 05.15.04 help
    I just bought an iPhone 3G 4.2.1 FW with 05.15.04 BB on craigslist (previously had a 2G iPhone and unlocking/jailbreaking that was a breeze)

    I need to unlock the phone to use it on T-Mobile

    What is the best way to jailbreak/unlock my phone so that it is untethered?

    I was going to use greenpois0n until I read somewhere that the phone can't be unlocked afterwards?

    I've done a lot of research on the net but I just wanted to get some clarification before I used redsn0w or greenpois0n and did any irreversible damage

    If I have to upgrade to BB 6.15.0 it wouldn't be the end of the world.. I just really don't want my phone to be tethered!

    Some help would be great!
    Last edited by martymvpturco; 2011-06-22 at 06:58 AM.

  2. #2
    This guide made it easiest for me..

    iClarified - iPhone - How to Jailbreak and Unlock Your iPhone 3G Using RedSn0w (Windows) [4.2.1]

    You can also check out this thread....

    http://modmyi.com/forums/general-iph...-15-04-bb.html

    .... as I probably asked many of the same questions you are thinking of...


    EQ

  3. The Following User Says Thank You to ESI For This Useful Post:

    martymvpturco (2011-06-22)

  4. #3
    Thanks ESl.. your links did help, but I still don't know if that method of jailbreaking is tethered or untethered

  5. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    The jailbreak will be untethered jailbreak, but once you have installed ipad baseband, if you ever need to restore to 4.2.1 again, it has to be a custom firmware not stock 4.2.1 anymore as there is a baseband check which cannot be kicked out by irecovery from TU.

  6. #5
    Quote Originally Posted by iYeow View Post
    The jailbreak will be untethered jailbreak, but once you have installed ipad baseband, if you ever need to restore to 4.2.1 again, it has to be a custom firmware not stock 4.2.1 anymore as there is a baseband check which cannot be kicked out by irecovery from TU.
    Okay good. The battery life on this 3G isn't the greatest. If I had to plug it in the computer everytime it died to jailbreak it again then that would be a pain!

    I'm going to jailbreak with redsn0w tonight and unlock with ultrasn0w

  7. #6
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Ok, good. Let us know

  8. #7
    Quote Originally Posted by iYeow View Post
    Ok, good. Let us know
    Well, the Jailbreak went fine but now after I unlocked with ultrasn0w, my phone won't get any service using my T-Mobile simcard.

    I've tried uninstalling and reinstalling with no success. I even used a different ultrasn0w from cydia.heaveniphone.com and have had no luck.

    I've been searching for solutions for the past 2 hrs with no luck.

    Please help!

  9. #8
    did you use the 6.15.00 baseband?

  10. #9
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    +1, go check your baseband, if your bb is 05.15 , then you have to update to ipad bb.

    And you know that you have to turn off 3g to get service for T-mobile.

  11. #10
    Quote Originally Posted by AAred View Post
    did you use the 6.15.00 baseband?
    Quote Originally Posted by iYeow View Post
    +1, go check your baseband, if your bb is 05.15 , then you have to update to ipad bb.

    And you know that you have to turn off 3g to get service for T-mobile.
    Yeah its the 6.15 iPad BB. 3G is turned off. I have reset my network settings several times, airplane mode, etc but it won't work!

    I got it to work for about 10 minutes, then I rebooted my phone and it went back to "No Service"

    It's so frustrating!

    Is there a fix for ulrrasn0w?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •