Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 4.2.1 jailbreak problems

  1. #1
    Default 4.2.1 jailbreak problems
    I have a 3G on 4.2.1. I ran greenpois0n and it runs just fine. I install cydia and Cydia installs but crashes immediately after I open it so I rerun the jailbreak. Now no matter what I do, Greenpois0n works but the loader tells me that cydia is already installed when I try to install it (because it is already installed just flawed). There is no way to delete cydia and there is no way to reinstall it since the loader wont let me. Restoring is not an option since it's not my phone so does anyone have any ideas? I think I could jailbreak 4.2.1 using redsn0w (tethered) and then use greenpois0n to untether it but I cannot find any working links to redsn0w 0.9.6rc6/7. Any ideas?

  2. #2
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Unless I'm losing my mind, redsn0w 0.9.6rc17 (most current version available here) should also work for iOS 4.2.1 on the 3G. That should install your Cydia (or send over an SSH bundle and you can go in and work on it via DPKG).

  3. The Following User Says Thank You to Orby For This Useful Post:

    kraziebone (2011-06-10)

  4. #3
    The SSH method is not possible without open SSH is it? I am trying redsn0w rc17 right now and it seems to be working! I didnt think redsn0w was backwards compatible with previous firmware but I guess I was wrong.

    It worked by the way so I appreciate the help.
    Last edited by kraziebone; 2011-06-10 at 02:26 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •