Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: My bootloader and baseband.

  1. #1
    Default My bootloader and baseband.
    Hi all, I got two question for you:

    1.) If I bought a 1.1.4 OTB iPhone, what bootloader and baseband does it come with?

    2.) Do firmware upgrades from apple update both the bootloader and the baseband or just one?

    Thanks for all your help.

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    You have bootloader 4.6 and baseband 4.04

    Firmware upgrades sometimes upgrade the baseband but not the bootloader.

  3. #3
    so the bootloader stays constant throughout, you cannot upgrade the booloader and apple's firmware upgrades do not change the bootloader. Am I right?

    thanks a lot.

  4. #4
    Green Apple
    Join Date
    Feb 2008
    Location
    Manchester UK
    Posts
    76
    Thanks
    10
    Thanked 17 Times in 16 Posts

    Basebands always change with firmware updates...
    1.1.1 was 04.01.13_G,
    1.1.2 was 04.02.13_G,
    1.1.3 was 04.03.13_G.
    1.1.4 was 04.04.05_G,
    1.2.0 Is (i believe) 04.05.00_G

    So yeah the baseband always changes, but the bootloader always stays the same throughout updates and restores. I think it'd cause Apple too many problems if they
    wanted to upgrade a bootloader through an online update, if something went wrong
    they'd have thousands, possibly hundreds of thousands of bricked iPhones
    Modding my iPhone since Feb 08! lol

    If anything i say helps you, please click the thanks button!

  5. #5
    so what is the difference between different bootloaders?

    if apple does not update the bootloader, how does a person who bought the first iphone have the latest software?

    thanks for all the help.

  6. #6
    Retired Moderator dale1v's Avatar
    Join Date
    Sep 2007
    Location
    London, UK
    Posts
    3,784
    Thanks
    335
    Thanked 395 Times in 268 Posts

    The bootloader used to determine how easy it was to unlock a phone. iPhones with a 3.9 bootloader were easy to deal with (there was a bug in it that could be exploited). 4.6 however, for a long time, was unable to be unlocked by software, due to the exploit being closed. You had to use a different sim to trick the phone into thinking it had an AT&T/O2/T-Mobile/Orange SIM card. Recently, this situation has changed, and both versions of bootloader and baseband combination are software unlockable.
    At the moment, there is no advantage of having one over the other. You won't notice any differences
    Last edited by dale1v; 2008-03-20 at 08:31 PM.

  7. The Following 2 Users Say Thank You to dale1v For This Useful Post:

    eyeandi (2008-03-22), Topper (2008-04-19)

  8. #7
    So my understanding so far is that there have been only two bootloaders from the start: 3.9 and 4.6. Apple updated the 3.9 version to kill the bug that allowed us to unlock the iphones.

    Am I right?

    thanks.

  9. #8
    Retired Moderator dale1v's Avatar
    Join Date
    Sep 2007
    Location
    London, UK
    Posts
    3,784
    Thanks
    335
    Thanked 395 Times in 268 Posts

    I think there is version 3.8 bootloader as well. Not as well known.
    You are right so far

  10. #9
    I think apple is going to launch another Bootloader with the 1.2 OTB

  11. #10
    Retired Moderator dale1v's Avatar
    Join Date
    Sep 2007
    Location
    London, UK
    Posts
    3,784
    Thanks
    335
    Thanked 395 Times in 268 Posts

    Apple themselves don't deal with the the bootloader chip; a company called Infineon do it, which is why it's not easy for Apple to change it often.

  12. #11
    Green Apple
    Join Date
    Feb 2008
    Location
    Manchester UK
    Posts
    76
    Thanks
    10
    Thanked 17 Times in 16 Posts

    I read on a website that there is a few bootloaders that are being discovered... Someone had a Bootloader 3.8, and Bootloader 3.1 has just appeared aswell... though not much is known about them, except that they are possibly bugs caused by iTunes... although i'm not sure on that
    Modding my iPhone since Feb 08! lol

    If anything i say helps you, please click the thanks button!

  13. #12
    I read from an interview with Zibri that you CAN reupgrade bootloader to 4.6 (after 4.6 to 3.9 downgrade) by using bbupdater, can anyone confirm? here is the source.

    http://ipodtouch4all.com/2008/03/09/...m/#comment-316

    or am i missunderstanding?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •