Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Need some advice. Respring takes forever, sometimes freezes

  1. #1
    Default Need some advice. Respring takes forever, sometimes freezes
    I posted this on a different forum earlier today but am hoping to find some new perspective here.


    Need some advice. Respring takes forever, sometimes freezes
    I'm fairly new to jailbreaking, but have been doing fairly well so far. The first time I did it, I installed all kinds of new apps, and eventually, the respring took forever, sometimes hours, when installing a new app or updating winterboard. I decided the remedy was to rejailbreak and in doing so, install the latest iOS, 4.3.2.

    Everything was working great until I installed LockInfo last night. Now if I do anything that requires a respring, it's an hour or more before it is usable again. Sometimes I need to quit the process and force a restart as it freezes.

    I don't have any cracked apps. I have purchased them all. I would like to experiment with themes in Winterboard, but not if it takes this long to get the phone running.

    Any ideas, suggestions, anything at all, would be very helpful. If you need additional info, let me know.

    I'm running the following mobile substrates:

    Activator
    DisplayStack
    FakeLocation
    FakeOperator
    IconSupport
    Infinifolders
    Lockinfo
    MobileNotifier
    Notified
    PhotoAlbumsPlus
    PreferenceLoader
    RemoveBG
    UIHook-iKeyEx3
    WinterBoard
    biteSBarClient
    biteSMSsb
    libhide
    libstatusbar

    Thanks!

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Start uninstalling the last apps like lockinfo until your repspring comes back to normal. You could have installed some stuffs from Cydia that conflicts with each other.

  3. #3
    That was happening to me a lot on 4.2.1 on both my iPhone & iPad. One day I started just turning the device off the normal way by holding the power button down and turning back on for a normal full boot instead of allowing or choosing a respring. This always worked well for me. (I powered down as soon as the 'restart springboard' screen would appear in Cydia.) It never crashed into safe mode and eliminated the 5-60 minute resprings when I'd be waiting and hoping it wouldn't boot loop on me. I also did this when changing something in sbsettings that would normally force a respring. YMMV, but it worked for me for several months. Happily, I just JB 4.3.3 yesterday with RedSnow and the respring problem has disappeared. There are a few things from Cydia I have not reinstalled though, so I don't know if the problem is gone forever or if I unintentionally eliminated a conflict. I did not restore from backup.

  4. #4
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Do as iYeow said to remove Cydia packages to find possible culprits. If even that isn't helping you'll probably want to restore and set up as new.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •