Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Stuck in Recovery Mode with "1015" error.

  1. #1
    Question Stuck in Recovery Mode with "1015" error.
    Hello,

    My iPhone is "stuck" in recovery mode.

    It shows see a screen with a white USB cable "pointing" to a blue iTunes icon. When I connect the phone to iTunes, iTunes tells me it has detected an iPhone in restore mode and must be restored before it can be used.

    So I click the "Restore" button, but after a few minutes of the apple logo on the iPhone screen, iTunes gives this error:

    ------------------------
    An unknown error occurred (1015).
    ------------------------

    I then tried loading Tiny Umbrella and click the "Exit Recovery" button. Immediately the iPhone screen goes blank and then the Apple logo appears. But after about 35 seconds, the same white USB "pointing" to a blue iTunes icon comes back onto the iPhone… and iTunes says it has detected an iPhone in recovery mode…

    … and I'm right back to where I started.

    Any ideas on how to fix this problem? Ultimately I would like to upgrade the iPhone to "iPad" baseband with iOS 4.3.3, so I can unlock it.

    Here is what TinyUmbrella shows:

    Baseband: 05.15.04-6.4_M3S2
    Firmware: 4.2.1

    Any assistance would be very much appreciated.

    Thanks!

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    If your iphone currently hasn't updated to ipad baseband, you shouldbn't be getting 1015, make sure you don't have any firewall blocking itunes from accessing the apple server.
    If you have TU installed, run it and under advance option, uncheck : set hosts file to cydia, save it and close it.
    Try again, do a reboot on your computer, make sure itunes is being updated first, downmload the 4.3.3 firmware from the google search of iclarified.com , shift + restore again to 4.3.3 ipsw

  3. #3
    Thanks very much.

    The problem continues.... here is what I did:

    1. Reboot my computer.

    2. Shut down my firewall software.

    3. Ran TinyUmbrella and unchecked the "set hosts file to cydia". Saved and then closed. (And also verified the two entries at the bottom of the hosts file now have number-sign comments in front of them.)

    4. Ran iTunes, and clicked the "Restore" button. It gave some info/warning about downloading the latest version (I clicked OK/Agree) and then it downloaded a big file. Eventually (after the download) the apple icon appeared in the iPhone. Then the "progress bar" appeared and iTunes said it was "Restoring iPhone firmware". The progress bar on the iPhone got to about 3/4 finished, and then suddenly the same "1015" error appeared in the iTunes window, and the USB-pointing-to-itunes-icon is back on the iPhone.

    5. I rebooted again.

    6. I turned off the firewall.

    7. Started iTunes, shift-click on the "Restore" button, selected the "iPhone2,1_4.3.3_8J2_Restore.ipsw" file I got from iClarified. (link)

    8. After about 3/4 through the restore... the same error message pops up again.

    Any ideas?

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    If restoring to stock firmware still gives you error 1015, then try restoring to custom firmware of 4.3.3 created by Pwnage tools 4.3.3 or get it from the net. Remember to use Redsn0w RC15, browse to stock 4.3.3 to just put your iphone into DFU mode before you Shift + restore in itunes.

  5. #5
    Hello,

    I have Windows, so I can't use Pwnage tools. However, I have both redsn0w v0.9.6rc16 and sn0wbreeze v2.7.3.

    It did not work with sn0wbreeze... but it DID work with redsn0w.

    For anyone who's in the same situatnio and reading this, here's what I did:

    1. sn0wbreeze 2.7.3. I use the "iPhone2,1_4.3.3_8J2_Restore.ipsw" file and build a custom file. I enter DFU mode using the instructions provided, and then hit shift-restore and navigate to the custom file on my desktop and start the restore. It gets about 3/4 done (according to the progress bar under the "snowflake" icon) and then the same "1015" error occurs in itunes. The device reboots, and I'm back to the "usb pointing to itunes icon" screen. (So basically exactly the same thing happens as when using stock firmware, except the custom firmware has a snowflake "progress bar" instead of an apple.)

    2. redsn0w 0.9.6rc16. I use the "iPhone2,1_4.3.3_8J2_Restore.ipsw" file and go through the steps to enter DFU mode... but it hangs for a few minutes with the pinapple on the screen and the status of "Flashing Baseband (don't interrupt!)". Eventually the iPhone reboots, and YIPPEE!! I see stock 4.3.3 firmware login screen.



    Now I will go to cydia, install ultrasn0w, pray it will unlock, and then install PKGBackup and pray all my old apps will be re-installed...

    Thanks very very very much to everyone who helped me!!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •