Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone says device isn' t eligible for the requested build? iPhone 4

  1. #1
    Default iPhone says device isn' t eligible for the requested build? iPhone 4
    Trying to upgrade to 4.3.3 from 4.2.1 "jailbreaked" through iTunes and halfway through the process I get "device isn' t eligible for the requested build" I am confused, please help, thank you!

    never mind, I just put my phone into DFU and it allowed me to update
    Last edited by grandmastertook; 2011-05-13 at 10:45 AM. Reason: Automerged Doublepost

  2. #2
    iPhone Underground A3gOwner's Avatar
    Join Date
    Jun 2009
    Location
    Underground
    Posts
    1,172
    Thanks
    2
    Thanked 117 Times in 110 Posts

    Thats weird but I'd suggest downloading this http://appldnld.apple.com/iPhone4/04...2_Restore.ipsw to your desktop and while holding shift, hit restore in iTunes, in box that pops up navigate to your desktop and select the above downloaded ipsw. See if it'll go threw that way.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •