Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Has the vibrate bug with the silence switch been fixed yet?

  1. #1
    Default Has the vibrate bug with the silence switch been fixed yet?
    I had jailbroken at 4.2.3 but the silence switch on the phone would vibrating when I would turn the silence switch to the off position. Someone on here commented on my post about it and said it was a bug in the 4.2.3 jailbreak. I was wondering if it still persists with the 4.3.3 jailbreak using Redsn0w?

    I'm running Windows 7, iPhone 4...btw...whatever happened with Limera1n and Greenp0ison? I thought they were going to be the permanent jailbreak tool after that hardware exploit was found in the processor?
    "Don't hold it like that!"

  2. #2
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by Dayvidpriddy View Post
    I had jailbroken at 4.2.3 but the silence switch on the phone would vibrating when I would turn the silence switch to the off position. Someone on here commented on my post about it and said it was a bug in the 4.2.3 jailbreak. I was wondering if it still persists with the 4.3.3 jailbreak using Redsn0w?

    I'm running Windows 7, iPhone 4...btw...whatever happened with Limera1n and Greenp0ison? I thought they were going to be the permanent jailbreak tool after that hardware exploit was found in the processor?
    redsn0w 0.9.6rc16 fixes the issue. Just re-run it over your (4.3.3 only) current jailbreak (making sure to NOT select "Install Cydia") and you'll get the fix (plus improved battery life).

    Those jailbreak tools are only usable as long as the other exploits they utilize work, or they are updated. The root exploit lives on in the updated tools (though you can use greenpois0n's underlying toolkit if you have a correctly patched/exploited kernelcache and iBSS, then run a ramdisk).

  3. #3
    OK, well I'm actually not jailbroken now...it was annoying me so I did a restore. So if I jailbreak with the current redsn0w the problem won't be there now?

    Thanks
    "Don't hold it like that!"

  4. #4
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by Dayvidpriddy View Post
    OK, well I'm actually not jailbroken now...it was annoying me so I did a restore. So if I jailbreak with the current redsn0w the problem won't be there now?

    Thanks
    Correct (according to iPhone Dev Team).

    And you're welcome.

  5. #5
    It's not supposed to vibrate again when turning switch back to ringer mode? I'll be. Mine has always done that. I'm on 4.3.2 now i4 and it still does it. Guess it just seemed normal for that to happen.
    Holy crap! I just checked an i4 on 4.0.2 and it doesn't vibrate when turning off or on! My world has been officially rocked.... And over something so simple.


    Sent from my iPhone using ModMyi

  6. #6
    Quote Originally Posted by orbyorb View Post
    Correct (according to iPhone Dev Team).

    And you're welcome.
    as a second opinion redsn0w0.9.6rc16 does fix it (personal experience)

  7. #7

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •