My phone is an iPhone 3G on T-Mobile. It was originally jailbroken on a 3.x, upgraded to 4.0, and then jailbroken again. At some point along that chain, after working fine with 4.0 for months, without change of Cydia packages; the bluetooth stopped working after a reboot. What I mean is this:

Trying to enable Bluetooth always follows the same pattern:
A) Open Settings->General->Bluetooth
B) The switch is in the OFF position
C) Click switch
D) Switch replaced by activity spinner
E) Spinner fades replaced with switch in OFF position again.

I've tried a few other methods such as SBSettings to enable it, which produces a very similar result. Other things tried and failed were:
-Various reboot/Airplane mode toggles
-Restored from backup
-Upgraded FW

In the interest of keeping things spicy, I decided this could be software or hardware; one being a little easier to diagnose. I updated to 4.1 via PwnageTool&iTunes, then restored my backup for personal data. Same issue as before.

Is it possible the BT radio is just hosed on this phone? Is there a bluetooth plist somewhere that I can delete to give it a fresh start? Are there any known issues/conflicts that I may not have found in extensive Google whoring? The only solutions were aimed at 3.1.x devices, and didn't work on mine.