Page 1 of 2 12 LastLast
Results 1 to 20 of 28

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS 4.0 restoring to the 4.0 again possible?

  1. #1
    Default iPhone 3GS 4.0 restoring to the 4.0 again possible?
    I bought a iPhone 3GS that was on 4.0 recently..I believe he had it jail broken and had a lot of files on theres still when he sold it to me. I didn't know that erasing all contents and data would erase the entire OS as well so now I'm stuck. I need the phone to be able to be unlocked, and it seems I need to restore it as well. I don't think/not sure if he saved the shsh blob from when he had it.

    I've tried to loaded a custom firmware 4.1 on there but it kept giving me errors (1600, 1604 are the most recent ones), and from what I have researched I can't downgrade to another firmware if the shsh blob isn't saved, I'm unsure (I don't think it was saved by previous owner).

    What are my choices?

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Download tiny umbrella: The Firmware Umbrella - TinyUmbrella
    Press save SHSH with your device connected and see what you are able to get.

  3. #3
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    Apple is currently signing 4.1. You should not have problems loading 4.1.

    As long as you used pwnagetool, snowbreeze, or redsnow to place you phone into DFU mode .. it should load. Tiny Umbrella will kick it out if recovery mode whereby you could analyze the log files.

    For my money (aka guess), you have a different problem, unrelated to any version.

    Has the battery been replaced?An incorrect one will cause loading problems and other battery related issues.

    If you have 3.1.2 SHSH blobs, try to load that. If it works, then I am sure the wrong battery is installed.
    Last edited by Mes; 2010-11-21 at 03:45 AM. Reason: Automerged Doublepost

  4. #4
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    I'm not sure he has a battery issue just from the info he provided. Those errors usually mean he hasnt put the device into dfu properly with sn0wbreeze/redsnow.

  5. #5
    I don't believe the battery has ever been replaced. I have no idea if any shsh was ever saved on the phone itself since I am not the original owner.

    Yeah I would have zero problems loading the default 4.1 on it, but I do not want to update the baseband that's on there now which would disable me from having it unlocked.

    I've tried to open TinyUmbrella I'm having trouble figuring out how to use it. I'll try it again and update to see what happens.

    Thanks

  6. #6

  7. #7
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    x98car believes your problem is DFU mode....

    So, let's go with that. Where did you get the custom firmware? What version (4.1?), Then how did you get into DFU mode?

    Quote Originally Posted by quakerroatmeal View Post
    ...Yeah I would have zero problems loading the default 4.1 on it, but I do not want to update the baseband that's on there now which would disable me from having it unlocked...
    FYI: With a 'custom firmware' and SHSH blobs you can load ANY version and the baseband will NOT be updated.
    Last edited by Mes; 2010-11-21 at 04:07 AM. Reason: Automerged Doublepost

  8. #8
    I got the phone to recognize once by TinyUmbrella but the device doesn't say the name like my iPhone 4 device says, I believe it says unknown device. I messed around and could not get it to show up again. A moderator PM me and told me to install redsn0w and have it enter DFU mode through there and sent me a custom ipsw. I will see if that will work. I'll update to see if it works I sure hope so. I made the custom firmware through pwnage tool 4.1 at first with the original 4.1 ipsw. Than I held the power home key release power key after 10seconds held home key until my iTunes recognized it. I shift restored but it won't even get pass preparing iphone to restore. It would give me an error after a few minutes.

    I'll let you know how DFU mode through redsn0w goes with custom ipsw that a moderator sent me goes.

    I'm really unsure if there's any SHSH Blob saved for this phone. I can't seem to get tinyumbrella to recognize the phone again. I ran it as administrator as well.

    The only thing I knew about the phone was he had custom themes it seem, and that it was on 4.0

  9. #9
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You have a 3gs or iphone 4

  10. The Following User Says Thank You to iYeow For This Useful Post:

    quakerroatmeal (2010-11-21)

  11. #10
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Sorry, if you are in boot loop then tiny umbrella wont recoginize it. I should have picked up on that. If you made a custom firmware with pwnage tool (I assume using vmware) then that should be fine, you shouldnt need another. Your issue was the way you entered dfu mode. The mod was right in that you should use redsnow 0.9.6b2 to enter pwned dfu so that the custom restore will work.

    Quote Originally Posted by iYeow View Post
    You have a 3gs or iphone 4
    He has a 3GS
    Last edited by Simon; 2010-11-21 at 04:29 AM. Reason: Automerged Doublepost

  12. The Following User Says Thank You to Simon For This Useful Post:

    quakerroatmeal (2010-11-21)

  13. #11
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You cannot retrieve your shsh blogs if your iphone is not bootable.

    Ok , cool, just do what i said to you. Update your itunes first and then do the rest.
    Last edited by iYeow; 2010-11-21 at 04:31 AM. Reason: Automerged Doublepost

  14. The Following User Says Thank You to iYeow For This Useful Post:

    quakerroatmeal (2010-11-21)

  15. #12
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    Loading 4.1 is no problem with (or without) SHSH today because Apple will supply.

  16. The Following User Says Thank You to Mes For This Useful Post:

    quakerroatmeal (2010-11-21)

  17. #13
    Holy smokes I followed iYeow's instructions and right now the phone actually went to the apple logo/status bar at the moment. It looks like it might install this time.

    The phone I'm working on is a iPhone 3GS.

    And I'm looking at it right now the status bar is moving! Woohoo *crosses fingers it works!!!!*

    THANKS iYeow! AND everybody else who helped as well! I am amazed I got so many responses very fast.

  18. #14
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Ummm... I did say your issue was how you entered dfu mode in post #4...

  19. The Following User Says Thank You to Simon For This Useful Post:

    quakerroatmeal (2010-11-21)

  20. #15
    So it did not work because I was not entering DFU mode correctly?

  21. #16
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Yeah, this is the best website for idevice help.

  22. The Following User Says Thank You to iYeow For This Useful Post:

    quakerroatmeal (2010-11-21)

  23. #17
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Quote Originally Posted by quakerroatmeal View Post
    So it did not work because I was not entering DFU mode correctly?
    In a nutshell yes, that is the reason. Which using redsn0w fixed. Normally pwnage tool would do this for you but that doesnt work right when using a virtual osx.

  24. The Following User Says Thank You to Simon For This Useful Post:

    quakerroatmeal (2010-11-21)

  25. #18
    Thanks so much..I thought I was entering DFU all along. Only took my entire saturday to get this working. I was pulling hair out and going nuts.. the phone is back in working order on 4.1 and baseband 05.13.04

  26. #19
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    you were entering dfu mode right. You just werent entering a pwned dfu state which is what is needed for a custom firmware to work.

    Quote Originally Posted by iYeow View Post
    Yeah, this is the best website for idevice help.
    That is certainly the truth
    Last edited by Simon; 2010-11-21 at 04:43 AM. Reason: Automerged Doublepost

  27. The Following User Says Thank You to Simon For This Useful Post:

    quakerroatmeal (2010-11-21)

  28. #20
    Ah I did not know there was another DFU mode for custom firmware. Learn something new everything.

    I went to cydia, and it says my shsh is ios 4.1, how would I save my shsh on this phone so I will always be able to downgrade? Open it in tinyumbrella and save shsh would do?
    Last edited by quakerroatmeal; 2010-11-21 at 04:45 AM. Reason: Automerged Doublepost

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •