Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cannot update to iOS 4.0 on 3gs

  1. #1
    Default Cannot update to iOS 4.0 on 3gs
    I ran tinyumbrella and retreived my SHSHs from Cydia. It show SHSHs for 4.0, 4.0.1, 4.0.2, and 4.1. I started the TSS server and confirmed that it was connected via the log then opened iTunes (ver 10) held the shift while clicking restore and selected the restore file for 4.0. Without hesitation I get the error "...could not be restored because the firmware file is not compatible"

    It is as if tinyumbrella is not intercepting the request for the hash.

    I've tried everything I can think of on my end. Any suggestions would be greatly appreciated.


    3gs running iOS 3.1.3

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Did you download the right ipsw for your device? On a 3GS it should begin with iphone2,1

  3. #3
    yes, that is the file i have (iPhone2,1_4.0_8A293_Restore.ipsw) I tired downloading it from several different locations hoping that it was a corrupt file that was causing the error.

  4. #4
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Are you running TU as administrator?

    Speaking of which, what windows version are you running?
    Last edited by i.Annie; 2010-11-05 at 07:12 AM. Reason: Automerged Doublepost

  5. #5
    Using Win 7 and only have it set up as administrator. Also clicked on "run as admin". Cannot find anything else running on port 80 that would block TU, but all of the shortcuts that I found for checking that were for older versions of Win.

  6. #6
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    That's what I was thinking. Windows 7 seems to have problems with jb tools and TU. Do you have access to another machine to try on? Like vista or xp or even better, a Mac?

  7. #7
    i do hae an older XP, but my phone is not synced there, will i lose my songs/data?

  8. #8
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    not as long as you restore only, once the restore is complete, hook it back up to your windows 7 pc and activate and sync it, FWIW I have windows 7 64 bit and have never had any problems with restoring, jailbreaking, or TU, what browser did you use to download the ipsw, if you used safari or I.E. try using chrome, firefox, or opera, I have seen nothing but trouble from safari and I.E. when it comes to downloading ipsw's

  9. The Following User Says Thank You to j3st3r For This Useful Post:

    docneon (2010-11-06)

  10. #9
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Just restore on the xp, then move over to your primary machine and resync on it to get your apps and music onto it. It's not recommended to restore from back up so you should back your stuff up manually to your comp. Then put it back in manually after setting up your phone as new. If you absolutely must restore from back up, just do so on your primary machine after you restore on the xp. Just be prepared, some problems might occur (it's not likely but can happen).

  11. #10
    Thanks for the info. I've used I.E. and Firefox. My guess was that it was because of Win 7, but who knows. I'm in the process of pdating my other computer...it had iTunes 7 on it...don't use it much.

    got the same error on the XP machine too. Maybe my phone doesn't want to be updated...
    Last edited by docneon; 2010-11-05 at 07:56 AM. Reason: Automerged Doublepost

  12. #11
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Weird. Have you tried setting your device into DFU or recovery mode (or try both if necessary) before doing the shift+restore?

  13. #12
    i'll have to try that again... tomorrow!

    same error...nothing works

    BTW, I also tried iOS 4.0.1 with the same results
    Last edited by docneon; 2010-11-05 at 08:09 AM. Reason: Automerged Doublepost

  14. #13
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Hm. Well I'm off to bed. I'll come back tomorrow to see what I can think of if nobody beats me to it

  15. #14
    I am completely at a loss. I think that either the SHSH obtained by Cydia is not valid or TU is not intercepting the server request. FWIW, I get the exact same response if I try to shift+restore without TU running...

  16. #15
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    When you run tiny umbrella, you must highlight the 4.0 shsh blogs in before you start Tss Server. Put your iphone into recovery mode if not then try DFU mode.
    Win 7 should be fine, my system is also Win 7.

  17. The Following User Says Thank You to iYeow For This Useful Post:

    docneon (2010-11-06)

  18. #16
    Tried all of those suggestions too... I think I'm screwed! I even tried another workaround where you replace the Apple's ip address in the host file with saurik's... so frustrating

    FYI, my baseband is 05.12.01 if that matters much...I even tried to update to 4.1 with TU and got the same error
    Last edited by docneon; 2010-11-06 at 12:11 AM. Reason: Automerged Doublepost

  19. #17
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    You said you tried updating without TU and even that didn't work? What kind of error do you get when doing that?

  20. The Following User Says Thank You to i.Annie For This Useful Post:

    docneon (2010-11-06)

  21. #18
    Same thin, "firmware not compatible". I give up. Thanks for all you help

  22. #19
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    This is a tough one... I don't wanna resolve to saying it's a hardware problem or a corrupted installation that's preventing overwriting with a stock firmware. Man lol I don't know what to say...if a standard upgrade doesn't even work then that's difficult.

  23. #20
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Quote Originally Posted by docneon View Post
    Same thin, "firmware not compatible". I give up. Thanks for all you help
    Check if you have a compass icon , then it is a 3gs

    If there is no compass icon , then it is a 3g.

    Firmware not compatible means you chose the wrong firmware type.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •