Whats going on i;m on 4.1 and I've tried a few times and it says that repo doesn't exist.. any idea whats going on?