Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone 4.0.2 jailbreak gone horribly wrong

  1. #1
    Default iphone 4.0.2 jailbreak gone horribly wrong
    okay, so ive been running JB'en 3.1.2 fw on my iphone 3G. i decided today to upgrade a JB 4.0.2... now heres the issue. i used redsn0w to jailbreak, using the 4.0 FW, everything went fine, got the pineapple logo, phone rebooted, then went to the invalid sim screen. i became frustrated trying to hacktivate it, and realized i cannot go into DFU mode. when i try to reboot, it goes to the spinning wheel, and then straight back to the invalid sim. since itunes wont do anything unless its a valid sim, i cannot downgrade. ive tried everything, but it seems like 0n 10/28/2010, apple decided to fix some hole which would have allowed me to hacktivate. i am at a loss. is my phone bricked? please help.

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    Put your iphone into DFU/Recovery mode and Do the Shift + Restore to 3.1.2 again.
    Error 1015 will pop up, use kick out of recovery from the feature of tiny umbrellla.
    Now you will be at Emergency Screen.
    Run Redsn0w 0.9.4 to jailbreak it.
    Let me know when you are jailbroken at 3.1.2 and I will show you how to get to a jailbroken 4.1 and still be able to unlock.

    Once you are jailbroken at 3.1.2 with Redsn0w.
    Download Snowbreeze 2.0.2 and download the official 4.1
    Create a custom firmware , if you have the official sim card, use Expert mode to uncheck the activate my iphone.
    Build it and it will be named as Snowbreez_4.1.ipsw on your Desktop.
    Put you jailbroken at 3.1.2 iphone into DFU mode
    Do the Shift + Restore to Snowbreeeze_4.1.ipsw
    Once restored you are already jailbroken at 4.1
    Open up Cydia and install Ultrasn0w to unlock.
    Last edited by iYeow; 2010-10-30 at 09:09 PM. Reason: Automerged Doublepost

  3. #3
    Limerain hactivates I believe

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    I don't think Limera1n can jailbreak a 3G

  5. #5
    okay, thank you for your help, i got that right before i checked this post out. so i am currently restoring my apps, photos, etc. im trying to install cydia through blackra1n, no luck. it seems my wifi signal degrades as it tries to download. now if i can bypass that and still have iOS 4, that would be great. i do plan on creating a one stop shop guide for n00bs, even tho im pretty much one myself. now im back to 3.1.2, JB'en, but not unlocked or with cydia. what do i do next? i do still want 4.0....

    BTW, i hardmodded my phone (3g), red faceplate (the glass around the digitizer), red housing, and i will post pics as a treat for those interested when i'm all done softmodding
    Last edited by nickdisney; 2010-10-30 at 10:47 PM. Reason: Automerged Doublepost

  6. #6
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You should jailbreak your 3g at 3.1.2 with Redsnow 0.9.4 , you do not need wifi to use Redsn0w.

    Then follow the my earlier post to restore to custom firmware to get you to jailbroken at 4.1 and you will be able to unlock with Ultrasn0w.
    Last edited by iYeow; 2010-10-30 at 10:59 PM. Reason: Automerged Doublepost

  7. #7
    My iPhone is a Part of Me iPittsburgh's Avatar
    Join Date
    Oct 2010
    Location
    Pennsylvania
    Posts
    981
    Thanks
    8
    Thanked 102 Times in 99 Posts

    Limera1n doesn't work on 3g as I've been informed by other mmi users. I'm no expert but when I've ran redsn0w 0.9.4 on an iPhone 3g with 3.1.3 and pointed to 3.1.2 it has worked perfectly more than 5 seperate occasions.

  8. #8
    okay, having issues. i am jailbroken on 3.1.2, trying to unlock, and i cant. i know its got to do with the baseband, but i can remember how to downgrade. its version 5.14.02, bootloader 5.09. youve been a great help so far, please help me this last time?

  9. #9
    My iPhone is a Part of Me iPittsburgh's Avatar
    Join Date
    Oct 2010
    Location
    Pennsylvania
    Posts
    981
    Thanks
    8
    Thanked 102 Times in 99 Posts

    Have you tried using fuzzyband (in cydia) to downgrade your baseband?

    And then use ultrasn0w to unlock.
    Last edited by iPittsburgh; 2010-10-31 at 06:47 PM. Reason: Automerged Doublepost

  10. #10
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    I think fuzzyband only works on the 5.8 bootloader

  11. #11
    okay, so it turns out that neither greenpois0n nor limera1n works for iphone 3g. looks like im screwed. anyone have any idea how to downgrade 5.09 and 5.14.02 on 4.1, 4.0, or 3.1.2?

  12. #12
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    NE Mississippi
    Posts
    381
    Thanks
    7
    Thanked 40 Times in 37 Posts

    Unless your 3G is on bootloader 5.8, it is currently *impossible* to downgrade the baseband. Thus, you will have to wait until the next ultrasn0w (sometime this month) to unlock.

    Firmware and Baseband are two different things. You can downgrade the firmware but not the baseband. Baseband version is what matter when it comes to unlocking. Once you get to a new baseband, you cannot go back regardless of the firmware version.

    The new redsn0w from last night will probably jailbreak your 3G on 4.1. Again, no unlock until after 4.2 hits.

  13. #13
    is there any way i can reflash the device back to factory settings? or am i completely screwed?

  14. #14
    Quote Originally Posted by nickdisney View Post
    is there any way i can reflash the device back to factory settings? or am i completely screwed?
    Sorry u are screwed until a new ultrasnow is released for the new baseband.

  15. #15
    didnt the courts rule its not illegal to jailbreak? why is apple so dead set on stopping us? i love the products, but they are the tyrants of the computing world. im currently trying the new redsn0w, so far so good, no idea what im going to do next. i found this in another forum. i am having trouble figguring out what hes talking about... is there a geek word for more than a n00b, less than an pro? middle n00b? a n00dle? thats what i am... a n00dle... check it out http://www.*****************/showthread.php?t=40593


    update: the new redsn0w didn't work. all i get is the connect to itunes screen. itunes wont update my FW. so now what? ive tried restoring to ipsw 4.0, 3.1.2, 4.01, 4.1, and i keep getting the 1015 errorand my phone stays on the usb itunes logo screen. im pulling my hair out at this point. what am i doing wrong?

    the jailbreak went through, no hitches 'cept this...
    Last edited by j3st3r; 2010-11-02 at 03:22 AM. Reason: removing reference to pirated apps repo

  16. #16
    Quote Originally Posted by nickdisney View Post
    didnt the courts rule its not illegal to jailbreak? why is apple so dead set on stopping us? i love the products, but they are the tyrants of the computing world. im currently trying the new redsn0w, so far so good, no idea what im going to do next. i found this in another forum. i am having trouble figguring out what hes talking about... is there a geek word for more than a n00b, less than an pro? middle n00b? a n00dle? thats what i am... a n00dle... check it out http://www.*****************/showthread.php?t=40593

    update: the new redsn0w didn't work. all i get is the connect to itunes screen. itunes wont update my FW. so now what? ive tried restoring to ipsw 4.0, 3.1.2, 4.01, 4.1, and i keep getting the 1015 errorand my phone stays on the usb itunes logo screen. im pulling my hair out at this point. what am i doing wrong?

    the jailbreak went through, no hitches 'cept this...
    U can jailbreak but not unlock until a new unlock is available.

  17. #17
    My iPhone is a Part of Me iPittsburgh's Avatar
    Join Date
    Oct 2010
    Location
    Pennsylvania
    Posts
    981
    Thanks
    8
    Thanked 102 Times in 99 Posts

    Run tiny umbrella and connect your iPhone then right click on your device and kick it out of recovery. This should get you out of recovery. If not I would shift restore to 3.1.3 and then use redsn0w 0.9.4 to jailbreak. As far as unlocking your iPhone you'll have to wait (I know it sucks) for the new ultrasn0w to be released hopefully later this month.

  18. #18
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    Quote Originally Posted by nickdisney View Post
    didnt the courts rule its not illegal to jailbreak? why is apple so dead set on stopping us? i love the products, but they are the tyrants of the computing world. im currently trying the new redsn0w, so far so good, no idea what im going to do next. i found this in another forum. i am having trouble figguring out what hes talking about... is there a geek word for more than a n00b, less than an pro? middle n00b? a n00dle? thats what i am... a n00dle... check it out http://www.*****************/showthread.php?t=40593


    update: the new redsn0w didn't work. all i get is the connect to itunes screen. itunes wont update my FW. so now what? ive tried restoring to ipsw 4.0, 3.1.2, 4.01, 4.1, and i keep getting the 1015 errorand my phone stays on the usb itunes logo screen. im pulling my hair out at this point. what am i doing wrong?

    the jailbreak went through, no hitches 'cept this...
    there is a reason that the forum puts ********** in that link, read the forum rules please, no pirates apps repo links are allowed

  19. #19
    okay, since i cant post the link, heres the post i found...


    If you can't wait for Fuzzyband 4.1 in cydia ... this is how I did:

    1) I downgrade the phone to ios4 and jailbreak with redsnow. (lucky that I saved the SHSH with firmware umbrella but I think you can use 3.1.x if you don't have SHSH or maybe just test it on 4.1) ... Then I update cydia through wifi and after that download fuzzyband 4.0~b4 (which is in cydia)
    2) I use ifunbox and transfer ICE2-05.14.02.cert file (plz unzip 1st) into raw file system > Applications > Fuzzyband.app folder
    3) NOW, this is where it gets tricky .... When using Fuzzyband, I have to try several times to downgrade ... if I get 'I Haz Downgrade' within 10 sec then it is not really success. If this happen, I will still see 5.14.02 in fuzzyband ... Have to try again slowly ... It took me about 15-18 tries (or less if you're lucky) before finally succeeded. The waiting cursor should be rotating about 2-3 minutes before getting 'I haz downgrade' prompt ... after this ... Fuzzyband should show baseband 04.26.08.

    btw, I didn't remove the SIM card during the process if it makes any difference.

    Now the phone is back to 4.26.08 .. I can finish up the restore process, and unlock using ultrasnow (and return back the phone to my friend) yeeeehaaaaa!

    Attached you will find the cert ... wish u all the best!

    ps: I am not responsible if you fail to downgrade even if you follow my steps ... like I said .. it will take a lot of patience ... maybe waiting 1 or 2 minute before reloading fuzzyband and retrying might help.

    EDIT : Please take note that downgrading baseband is ONLY POSSIBLE if your device have Bootloader 5.08. If your device BL is higher eg. 5.09, 6.02, 6.04 ... sorry ... forget about downgrading baseband and wait for 5.14.02 baseband unlock via ultrasnow.

    EDIT 2 : confirm working on ios4.1 as long as you have BL5.08. No need to downgrade ios firmware!

    EDIT 3 : I happen to have a copy of Fuzzyband 4.0b .. so here I attach Fuzzyband 4.0b : Fuzzyband40.zip . Make sure you try the latest fuzzyband 4.1 FIRST before using this version (you need to overwrite all files). This package includes all cert from BB 5.08.01 up to 5.14.02. Make sure you chmod 755 or change permission using winscp if it doesn't run (crash to springboard).

    disclaimer : all credits should go to Fuzzyband maker. The package above is only my backup. I am not responsible if you still unable to use the above attached file. It will downgrade to 04.26.08 and not 05.13.04 like the latest Fuzzyband.

  20. #20
    As yeow said before. When you get 1015 error you use TinyUmbrella to kick out of recovery, then you're restore will be complete.

    Your phone obviously got upgraded to 4.1 at some point so now you just need to jailbreak it on 4.1 and wait for the new ultrasn0w.

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •