Results 1 to 13 of 13

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G-S jailbreak requirements quiestions...

  1. #1
    Default iPhone 3G-S jailbreak requirements quiestions...
    hello this my first time posting to this site so bare with me for a bit. i've been searching on this site for quite a while and at the same time doing some research into Jailbreaking my iPhone 3G-S. now i did all the back up i needed to do in case i didnt want the jailbreak anymore. now my dilemma is that i came across was the recent firmware update to 4.1 then i read about limera1n and greenpois0n and also redsn0w have ios 4.1 jailbreaks. i downloaded the software (or at least so i thought) and tried to open it but my computer (powerbook G4) says "your computer cannot support this type of program/application". WTF!! are there any system requirements for jailbreaks? (i have MAC OSX 10.4.11) what is the requirement for the "oldest" MAC OS for jailbreaks? am i better off waiting for the "jailbreakme.com" release for 4.1? any help would be greatly gratified...

  2. #2
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    there will not be a jailbreakme for 4.1, I'm not sure what the requirements for the mac are on any of the jailbreak programs but I'm sure a google search will yield the answers, just glancing it appears that pwnagetool requires OSX 10.5.x
    Last edited by j3st3r; 2010-10-25 at 12:56 AM.

  3. #3
    iPhoneaholic reddawg's Avatar
    Join Date
    Sep 2008
    Location
    Massachusetts, USA
    Posts
    430
    Thanks
    39
    Thanked 71 Times in 59 Posts

    Quote Originally Posted by pulloa View Post
    hello this my first time posting to this site so bare with me for a bit. i've been searching on this site for quite a while and at the same time doing some research into Jailbreaking my iPhone 3G-S. now i did all the back up i needed to do in case i didnt want the jailbreak anymore. now my dilemma is that i came across was the recent firmware update to 4.1 then i read about limera1n and greenpois0n and also redsn0w have ios 4.1 jailbreaks. i downloaded the software (or at least so i thought) and tried to open it but my computer (powerbook G4) says "your computer cannot support this type of program/application". WTF!! are there any system requirements for jailbreaks? (i have MAC OSX 10.4.11) what is the requirement for the "oldest" MAC OS for jailbreaks? am i better off waiting for the "jailbreakme.com" release for 4.1? any help would be greatly gratified...
    You could try PwnageTool 4.1.2, it might work with OS X Tiger 10.4.11. I know it will work on Leopard 10.5.x and Snow Leopard 10.6.x.
    "When I die, I want to go peacefully in my sleep like my grandfather did...not kicking and screaming like the passengers in his car." -- Unknown

  4. #4
    thanks... im gonna give pwnagetool see if that works...i think i may just purchase a new mac if all else fails, whoopty doo fml

  5. #5
    iPhoneaholic dotFIVE's Avatar
    Join Date
    Sep 2010
    Location
    California
    Posts
    494
    Thanks
    9
    Thanked 82 Times in 79 Posts

    Quote Originally Posted by pulloa View Post
    thanks... im gonna give pwnagetool see if that works...i think i may just purchase a new mac if all else fails, whoopty doo fml
    Don't purchase a whole new Mac, just a Leopard OS update disc.


    Sent from my iPhone using ModMyi

  6. #6
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    Quote Originally Posted by dotFIVE View Post
    Don't purchase a whole new Mac, just a Leopard OS update disc.


    Sent from my iPhone using ModMyi
    Make sure it's Leopard and NOT Snow Leopard (pretty sure that will not run on a G4)

  7. #7
    Rather an expensive jailbreak? Why not use someone else's computer? The jailbreak only takes seconds.

  8. #8
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    Quote Originally Posted by westonben View Post
    Rather an expensive jailbreak? Why not use someone else's computer? The jailbreak only takes seconds.
    ^^^^^^^^

    this is true

  9. #9
    Quote Originally Posted by pulloa View Post
    hello this my first time posting to this site so bare with me for a bit.
    BTW, we don't do that sort of "bearing" on this site

  10. #10

  11. #11
    Quote Originally Posted by dotFIVE View Post
    Don't purchase a whole new Mac, just a Leopard OS update disc.


    Sent from my iPhone using ModMyi
    Give the guy a break!! He found a great excuse to buy himself a new computer AND jailbreak his phone.. come on. I say go for it, buy, buy buy...LOL

  12. #12
    @John1177: sounds like someone works at a retail store!! lol! trust me i would buy a new one. ive had my powerbook G4 for over 5 years now and ive had absolutely no problems until recently with software updates.

    @westonben & j3st3r3: i have considered getting a buddy and doing it that way but they all have WIN7 and i primarily use mac for security and CRASH reasons and also i dont want my friends have my backed up files that i encrypted on my phone. i havent really looked into leopard, last time i checked for me to upgrade i need a better machine. not that i dont already have a great computer but i need a more "recent" machine. but like i said i will look into it to see if i can upgrade to leopard
    ps i didnt want to refer to an animal when i wrote "bare".

    to everyone thanks for all the sarcastic help. i laughed and was informed. thank you

  13. #13
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    i know leopard will run on a G4, almost positive that Snow Leopard will not, at least from the brief reading I did on the subject

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •