Results 1 to 11 of 11

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 on 4.0.2 no signal bars problem

  1. #1
    Default iPhone 4 on 4.0.2 no signal bars problem
    Hi Guys,

    Recently bought an iPhone 4 that was locked to the 3 network. It was 4.0.2 baseband 1.59.00.

    Unlocked recently with limera1n and ultrasn0w. I am on Vodafone.

    Everything had been working fine for about 4-5 days and then suddenly my calls and texts stopped working. Can't phone out as it just goes 'call failed' and texts don't send.

    The odd thing is that all my internet services like whatsapp and facebook/email work fine.

    Now and again I get a 'waiting for activation, may take some time.' error.

    I get the current screen,



    As you can see it recognises the network, but I don't get any signal bars. It's not saying 'no service'.

    Any ideas?

    Thanks.

  2. #2
    Random Thanks Collector Richard's Avatar
    Join Date
    Mar 2008
    Location
    England (leeds)
    Posts
    1,615
    Thanks
    688
    Thanked 1,113 Times in 549 Posts

    If you unlocked with Ultrasn0w ? then just reinstall it and it should be fine again.
    . I Am the Random Thanks Collector So Please Press the Thanks Button

  3. #3
    Tried that, same problems.

  4. #4
    Drinks the Kool Aid Captinsmooth's Avatar
    Join Date
    Mar 2010
    Location
    New York
    Posts
    1,322
    Thanks
    131
    Thanked 351 Times in 199 Posts

    Download tinyumbrella and save your shsh for 4.1 then use tinyumbrella to upgrade your I4 to 4.1 while preserving your baseband so you can still unlock. Then rejailbreak with greenpois0n and unlock with ultrasn0w again.

    So in other words I am saying a restore will suite you best.

    Also don't restore from a backup, restore as new.
    Last edited by Captinsmooth; 2010-10-17 at 07:16 PM. Reason: Automerged Doublepost
    This post infers no rights and is provided as is.

    Click here to follow me on twitter

  5. #5
    Yeah I figured that would be the best idea.

    Just tried it and it's got the same problem.

    I don't understand.

    I used a fresh install of Greenpois0n and a fresh 4.1 .ispw

    How can something still be stored on the phone?

    Now it's not recognising the network and there is only 1 little bar. Argh!
    Last edited by Spikyhedgehog; 2010-10-17 at 08:08 PM. Reason: Automerged Doublepost

  6. #6
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Confirm you have the 1.59 baseband. Your symptoms are typical of a hacktivated but not unlocked phone.

  7. #7
    Yup, have reinstalled ultrasn0w a few times and no luck!


  8. #8
    Have you set your apn settings?

  9. #9
    Ok, retried it and I'm getting the original problem again.

    APN settings are all right because I can actually get a data connection, just don't get a phone connection.

  10. #10

  11. #11
    Argh this is just annoying now.

    Everything I try and the same thing happens?

    Could it be due to the fact that I actually have an iphone contract with Vodafone already, but am jailbreaking to unlock as the phone is locked to a different network?

    Is there any way to unlock after restoring without jailbreaking, then just activating as I would normally?

    One odd thing I've noticed, when I go to Cydia to reinstall Ulrasn0w it says that the 'Disk Using' is 0.0 B??

    Last edited by Spikyhedgehog; 2010-10-21 at 08:31 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •