Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3G[S] with iOS 4.0 GM and JB

  1. #1
    Angry 3G[S] with iOS 4.0 GM and JB
    Ok, I'm an iOS dev and I put the Beta's and GM's on my wife's phone for testing apps, when 4.0 officially came out, I connected her phone to iTunes and it said it was "Up to date"... but I hadn't bothered JB'ing her iPhone ever (no SHSH's anywhere).

    So I just saved a SHSH in Umbrella, not cydia. My only goal for her phone is to unlock it to use on T-Mobile, but everything I've read and looked at pretty much gives me a dead-end.

    When I got to jailbreakme.com, safari crashes:

    Code:
    Incident Identifier: 30293222-F9CD-4E5F-A9FB-924D5E509F62
    CrashReporter Key:   ba271eee7ee68eff5905bfa992a1bf90d5063241
    Hardware Model:      iPhone2,1
    Process:         MobileSafari [225]
    Path:            /Applications/MobileSafari.app/MobileSafari
    Identifier:      MobileSafari
    Version:         ??? (???)
    Code Type:       ARM (Native)
    Parent Process:  launchd [1]
    
    Date/Time:       2010-10-07 17:43:08.051 -0700
    OS Version:      iPhone OS 4.0 (8A293)
    Report Version:  104
    
    Exception Type:  EXC_BAD_INSTRUCTION (SIGILL)
    Exception Codes: 0x00000001, 0xfd5ff7ff
    Highlighted Thread:  0
    At this point, is there anything I should or should not do? I feel if I upgrade her to 4.1 I might be missing an opportunity to do something, but staying at 4.0 GM isn't doing any good either (I know it's 4.0 GM because it has the Game Center).

    Do any of the "paid" unlocking services advertised around work?

    Thanks for any positive input.

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,878
    Thanks
    8,108
    Thanked 17,646 Times in 8,026 Posts

    Hmmm... That's a tough one. Whatever you do don't update to 4.1 as that will render any chance of unlock impossible (at least right now).

  3. #3
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    If you don't have 4.0.1 shsh blogs, there is nothing you can do. GM IOS will definitely crash Safari. It is not for everybody , only for Dev Testing purposes.
    Check with Tiny Umbrella and request from Cydia if you can get the 4.0.1 shsh blogs.
    You are right, 4.1 is no good for now as there is no unlock yet.

  4. #4
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,878
    Thanks
    8,108
    Thanked 17,646 Times in 8,026 Posts

    Ya without SHSH you are stuck until a new jailbreak for 3GS comes out. At that point you will have to do the trick where you modify the firmware file so it errors out just before the baseband update part. I think that was detailed on the dev team site a while back. Last ditch I think it was called.

  5. #5
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,878
    Thanks
    8,108
    Thanked 17,646 Times in 8,026 Posts

    Or you can ask comex if he has a version of jailbreakme that might work for the 4.0gm. I doubt it but you never know.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •