Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help upgrading 3.1.3 3GS to unsigned 4.0+

  1. #1
    Default Help upgrading 3.1.3 3GS to unsigned 4.0+
    Trying to get this thing to run any unlockable FW at 4.0+. Can someone help me get things going here please.
    I have shsh for 3.1.3 only.
    Thank you

  2. #2
    Livin the iPhone Life jkmonkey's Avatar
    Join Date
    Mar 2010
    Location
    Upstate NY
    Posts
    1,433
    Thanks
    67
    Thanked 254 Times in 245 Posts

    If the only shsh's you have are for 3.1.3 then you will NOT be able to install any 4.x other than 4.1 which is not unlockable. On the other hand if you do have 3.1.3 then chances are that you really do have other shsh's. Use tinyumbrella to check cydia's server for 4.0 or 4.0.1.
    Last edited by jkmonkey; 2010-09-28 at 06:05 PM.

  3. #3
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    ^he meant not unlockable

  4. The Following User Says Thank You to i.Annie For This Useful Post:

    jkmonkey (2010-09-28)

  5. #4
    Livin the iPhone Life jkmonkey's Avatar
    Join Date
    Mar 2010
    Location
    Upstate NY
    Posts
    1,433
    Thanks
    67
    Thanked 254 Times in 245 Posts

    oops yeah I did

  6. #5
    Thanks, I just got the phone and all I have done is J/B and Unlock it.
    any ETA on a 4.1 J/B

  7. #6
    Quote Originally Posted by jkmonkey View Post
    If the only shsh's you have are for 3.1.3 then you will NOT be able to install any 4.x other than 4.1 which is not unlockable. On the other hand if you do have 3.1.3 then chances are that you really do have other shsh's. Use tinyumbrella to check cydia's server for 4.0 or 4.0.1.
    So he can't use a custom firmware to 4.0.1 and do the gs.apple.com block?

  8. #7
    Livin the iPhone Life jkmonkey's Avatar
    Join Date
    Mar 2010
    Location
    Upstate NY
    Posts
    1,433
    Thanks
    67
    Thanked 254 Times in 245 Posts

    Quote Originally Posted by shanejoe View Post
    So he can't use a custom firmware to 4.0.1 and do the gs.apple.com block?
    No, probably not. First off if your using a custom firmware you don't need to edit the host file at all. The custom firmware bypasses the verification process alltogether. Second the phone must have an old bootrom in order to use custom firmwares, new bootroms will not accept them. He didn't mention if it was old or new bootrom so that part is a maybe. Third if he has a 3GS that he jailbroke at 3.1.3 it was done with either spirit or jailbreakme. Niether of those two jailbreaks will allow the phone to accept a custom fw. If the phone IS an old bootrom spirit2pwn or jbme2pwn could be used to get the phone to a state that would accept the custom fw. Lastly editing the hosts file(gs.apple.com) only does any good if you have shsh's saved on cydia's server.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •