Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Problem upgrading to 4.0.1 on 3GS

  1. #1
    Default Problem upgrading to 4.0.1 on 3GS
    So i've read through a handful of topics like this, on this site and others, with no resolution to my problem.

    I've been at 3.1.2 for a while and wanted to move up to 4.0.1, having SHSH's with Cydia beginning at 3.1
    Having my Hosts file pointed to Cydia, i have been able to successfully restore to 3.1.2 again, though i continue to get errors with 4.0.1(often error 13), and i tried 4.0 with no luck also. It seems to get just past the verification part, then gives the error. I am in DFU mode with each attempt.
    I also tried TinyUmbrella with no luck too.

    I have an old boot 3GS. Using Windows 7 with iTunes 9.0.3. Have tried different cables and USB ports. Can successfully restore to 3.1.2 with Cydia's SHSH's. I have tried bare and custom firmwares.

    Any advice to get to 4.0.1? Try a different version of iTunes?

    P.S. My SHSH for 3.1.2 is about 64kB but for 4.0 and 4.0.1 is about 60kB - don't really know how to tell if this is the problem though.

  2. #2
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by joemamawilder View Post
    So i've read through a handful of topics like this, on this site and others, with no resolution to my problem.

    I've been at 3.1.2 for a while and wanted to move up to 4.0.1, having SHSH's with Cydia beginning at 3.1
    Having my Hosts file pointed to Cydia, i have been able to successfully restore to 3.1.2 again, though i continue to get errors with 4.0.1(often error 13), and i tried 4.0 with no luck also. It seems to get just past the verification part, then gives the error. I am in DFU mode with each attempt.
    I also tried TinyUmbrella with no luck too.

    I have an old boot 3GS. Using Windows 7 with iTunes 9.0.3. Have tried different cables and USB ports. Can successfully restore to 3.1.2 with Cydia's SHSH's. I have tried bare and custom firmwares.

    Any advice to get to 4.0.1? Try a different version of iTunes?

    P.S. My SHSH for 3.1.2 is about 64kB but for 4.0 and 4.0.1 is about 60kB - don't really know how to tell if this is the problem though.
    As long as your SHSH blobs are between, say, 60-70 KiB you should be okay. Blobs retrieved from Cydia (without originally getting them from Apple first via TinyUmbrella) are generally a touch smaller than those straight from Apple saved via TU. Also my 3.1.3 3GS blob is about 8.5 KiB larger than my 4.0 blob for the same device; both came straight from Apple via TU and I can confirm both are valid. Don't sweat it as long as you're around ~60 KiB.

    Your problem is probably in the iTunes version--iOS 4.0 requires iTunes 9.2 or later if I remember correctly. That oughta solve it; as error 13 is usually indicative of iTunes/IPSW mismatch (also occasionally a USB problem, but if you're syncing etc. normally on iOS 3.1.x I doubt it's this).
    Last edited by Orby; 2010-09-28 at 04:55 AM.

  3. The Following User Says Thank You to Orby For This Useful Post:

    joemamawilder (2010-09-28)

  4. #3
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You must update your itunes to the latest.
    When you have restored to 3.1.2, run Redsn0w 0.9.4 to jailbreak.
    Then you can restore again to custom firmware 4.1 made by Snowbreeze 2.0.2.

  5. The Following User Says Thank You to iYeow For This Useful Post:

    joemamawilder (2010-09-28)

  6. #4
    iPhoneaholic
    Join Date
    Mar 2010
    Location
    Iowa Park, Texas, United States
    Posts
    462
    Thanks
    44
    Thanked 29 Times in 28 Posts

    or just update your itunes.... download tiny umbrella.... retrieve SHSH's from cydia, then start the TSS sever and then do the restore and kick out of recovery if needed....

  7. The Following User Says Thank You to drog92 For This Useful Post:

    joemamawilder (2010-09-28)

  8. #5
    Jailbreak it with blackrain at 3.1.2 then just use snowbreeze custom firmware to go to 4.1, you don't need SHSH files to do this.

  9. The Following User Says Thank You to eyeRobot For This Useful Post:

    joemamawilder (2010-09-28)

  10. #6
    Thanks to all that posted, will be downloading a newer version of iTunes and let ya know how it goes.

    After updating iTunes, I am currently in the middle of restoring to 4.0.1. Initially i tried to go to 4.1 using a sn0wbreezed firmware, but continued to get error messages(1600 this time). I also got the same error when i was attempting to restore to 3.1.2 with sn0wbreeze the other day when the problems began. I will still try to go to a sn0wbreezed 4.1 just to see if i can. I have never had good luck with custom firmwares in the past, and it's not looking any different now.

    Again, thanks to all
    Last edited by joemamawilder; 2010-09-28 at 09:51 PM. Reason: Resolution

  11. #7
    Retired Moderator Orby's Avatar
    Join Date
    Aug 2010
    Location
    Omicron Persei Eight
    Posts
    5,851
    Thanks
    42
    Thanked 699 Times in 594 Posts

    Quote Originally Posted by joemamawilder View Post
    Thanks to all that posted, will be downloading a newer version of iTunes and let ya know how it goes.

    After updating iTunes, I am currently in the middle of restoring to 4.0.1. Initially i tried to go to 4.1 using a sn0wbreezed firmware, but continued to get error messages(1600 this time). I also got the same error when i was attempting to restore to 3.1.2 with sn0wbreeze the other day when the problems began. I will still try to go to a sn0wbreezed 4.1 just to see if i can. I have never had good luck with custom firmwares in the past, and it's not looking any different now.

    Again, thanks to all
    Make sure you're starting your blackra1ned 3GS restore to the custom firmware from Recovery Mode, not DFU or while running. That should do it...

    EDIT: If you've already started the restore to 4.0.1, ignore what I said about Recovery Mode, just run jbme and go from there once you're done.
    Last edited by Orby; 2010-09-28 at 09:55 PM.

  12. The Following User Says Thank You to Orby For This Useful Post:

    joemamawilder (2010-09-29)

  13. #8
    Got everything working. I'm now at 4.1 with an unlockable baseband by means of sn0wbreeze. My problem with sn0wbreeze must have been DFU mode. Worked like a charm with the new iTunes in recovery mode.
    I was at 3.1.2 for so long, i haven't been keeping up with the iPhone hacking world as much as i should. Been spending more time in the Wii hacking community.

    Thanks to all for the helpful replies. You have all been compensated with a "Thanks"

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •