Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help! iPhone 3GS bricked

  1. #1
    Default Help! iPhone 3GS bricked
    Ok so this is the situation I got myself into.. I just recently purchased a used iPhone 3GS running 3.1.3 with the old bootrom from a friend and the phone at the point of purchase was working perfectly. I activated the phone using an old AT&T sim card I had and jailbroke and unlocked the phone with jailbreakme and ultrasn0w respectively..

    After this point everything seemed to just fall apart. I was new to the iPhone so I figured it would be fine to update Cydia, so I did and I restarted the phone later that day and the phone wouldn't boot past the Apple logo. From what I researched it seemed like I fell victim to the infamous "Rock virus" that corrupted my /sbin. I can't restore to a older firmware because I don't have any shsh blobs saved and can't do a stock restore to 4.1 because I need to unlock to use it on T-Mobile.

    I've tried custom restoring to 3.1.2, 3.1.3, 4.0, and 4.0.1 using both Pwnagetool and sn0wbreeze but to no avail, all I ever get is a 1604, 1600, or 1601 error. I tried to fix the errors by doing all sorts of remedies I found on the internet but again that didn't do anything.

    Does anyone have any idea how I can get out of this situation? Any help would be greatly appreciated!

  2. #2
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You are screwed, you just jailbroke your 3.1.3 recently, so you will only have 4.1 shsh blogs saved. You cannot restore to custom firmware because you used Jailbreakme.com. You cannot restore to stock 3.1.3,4.0 and 4.0.1 because you don't have shsh blogs. You need the unlock so you cannot restore to 4.1 either. You are very screwed even though you have the old bootrom, this is my first time seeing this kind of worst case scenario on an old bootrom.

    Don't be too upset not to hit Thanks buttons below.
    Last edited by iYeow; 2010-09-22 at 06:21 AM.

  3. The Following User Says Thank You to iYeow For This Useful Post:

    Sibycus (2010-09-22)

  4. #3
    Tried putting it in Recovery mode as well - turn off unit hold home button plug wire in (keep holding home button) untill you hear it connect and itunes detects it.

    But i guess even that wont help just heard some stories that i can work is all, only thing to do is just restore to 4.1 for now untill it gets jailbroken , should of used tiny unbrella to save shsh locally .

  5. #4
    Ya I got the feeling that I was screwed after researching online but went for a last ditch attempt to try and salvage the situation. Thanks for the input and I guess I'll just have to hope that an unlock comes out for baseband 5.14.02 soon.. or ever for that matter.

    But is there anyway to actually fix the /sbin files to make the phone start without a restore? I read the stickied post by iBeej and was wondering if that would maybe be able to get me out of this situation. If not I kinda accepted the fate of my iPhone and will probably just wait patiently. Thanks again for all the help!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •