Results 1 to 1 of 1

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Jailbreaking a 3G with 3.1.3 on a Mac with iTunes 10?

  1. #1
    Green Apple
    Join Date
    Aug 2010
    Lost Androideles
    Thanked 3 Times in 3 Posts

    Default Jailbreaking a 3G with 3.1.3 on a Mac with iTunes 10?
    I bought an iPhone 4, so now I want to sell my old iPhone 3G. I wiped it clean and did a fresh restore of it to 3.1.3 (baseband 05.12.01). I'm going to try and sell it with 3.1.3 as there is clearly no reason to put 4.0.1/4.0.2 on a 3G.

    Now I want to Jailbreak and unlock it, but happened to peruse a thread on the Dev Team blog site before dragging out Pwnage Tool 3.1.5. I saw something early on in that thread saying that iTunes 10 breaks doing this (i.e. restoring from a Pwnage Tool 3.1.5-generated custom IPSW)? I only have iTunes 10 on the 3 Macs I have access to.

    Do I have any other choice but to revert one of them to iTunes 9?

    I thought maybe redsn0w 0.95 b5-5 would do it but I'm seeing things on the 'Net about 0.95 being for iOS 4.0.x or that 3.1.3 with baseband 05.12.01 is not supported, etc. I tried it anyway but when it ran it said it didn't recognize the 3.1.3 IPSW.

    Then I looked at trying Spirit but apparently it only works with iTunes 9.1.1 or older.

    Other people have mentioned using JailBreakMe.COM but I thought that was only for jailbreaking 4.0/4.0.1 devices?

    It's all a bit confusing. Any info that could clear this up for me would be appreciated.

    *** UPDATE ***

    Just for grins, I tried going to JailBreakMe.COM and it appears to have worked?!?

    Cydia is installed, it successfully did a Complete Upgrade ... maybe this worked?

    Anyway, loaded Ultrasn0w 1.1-1 as well, that seemed to take ...

    So maybe I'm out of the woods?

    If so, I have one other question:

    My original AT&T SIM is still in this phone, but it's been de-activated since I activated my recently-purchased iPhone 4. When I boot the iPhone 3G I naturally get "Waiting for activation/This may take some time" on the Home screen.

    I've seen other posts elsewhere where people have had their iPhones stuck in "Connect to iTunes" mode pending activation. I'm curious why I did not have that happen to me?

    But more importantly, I'm worried that once someone else buys the phone and gets their own SIM that the "No activation" might rear its ugly head and that Ultrasn0w unlock won't work once they try to use it because of lack of activation. Paranoia or justified worry?
    Last edited by RiotNrrrd; 2010-09-13 at 12:56 PM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts