I recently jailbroke my phone by simply typing in jailbreakme on my phone, and it did the work for me.
I downloaded and installed PDA net, after it wasn't recognized the first time. I have a laptop w/ WinXP, and followed the steps to set up an ad hoc network. When I tried setting up a WEP code, I got a bit error msg. and something else saying not enough characters in the same window. Since I did not understand this msg., I bypassed that option, however, when I set up the WiFi on my phone, I set a WEP key up in there. I am able to connect, and the connection shows Excellent and Secured, but when I click on a browser, I am unable to physically connect. My wireless card is enabled, and PDA is saying the router is on. I also noticed after updating and resyncing my 3Gs, before the jailbreak, that there's am option to tether your phone, and if you'd like to set it up, to contact AT&T, which I am afraid to do.
I am also unable to install BiteSMS, as it is not recognized by Cydia.
I tried deleting the new connection(s), but have been unable to do so.
Any suggestions would be greatly appreciated!

Thanks!