Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Problem! iphone 4 stuck in safe mode!

  1. #1
    Default Problem! iphone 4 stuck in safe mode!
    hi guys,.... im not exactly new to the whole jailbroken sceen but im new to this trouble shooting...

    first of all the specifics....
    im using iphone 4
    4.0.1

    i recently installed an app (iWeather Widget)
    and noticed that there was sum updates from ROCK to install, one of them being ROCK itself, other being iWeather Widget, and the third was intellishare
    i updated all three, said i needed to do a soft reboot,....

    performed the reboot and entered safe mode,

    these are the steps ive done so far but nothing has worked!

    1, i tried simply rebooting - did not work
    2, i tried uninstalling one by one and rebooting the three apps that were updated,
    3. i tried uninstalling all apps from rock/cydia that were not MUST haves from what i use everyday,
    4. i installed crash log from cydia (altho it doesnt say specificly what the cause was via the GUI from the app itself maybe there's something within all the code from the crash log that im missing...

    im pretty new to all the coding aspect of the iphone4 and ive been working on a FULL and complete theme for the iphone 4,... was getting very close to finishing it and doing all the testing... im pretty pissed this is goin on and i wont be able to complete it...

    so my questions are...
    1, can anyone help me resolve this without restoring my iphone?
    2. IF restore is needed, where can i find a copy of the 4.0.1 software so i will still be able to jailbreak?
    3. can anyone help me with my crash log and maybe theres some hidden info in there im not seeing....?


    PLEASE HELP ME!!
    help with resolving this issue will be rewarded via paypal payment :wink:
    for a lil incentive and to show my appreciation!!

    update!

    found the 4.0.1 software

    wondering still if it can be fixed without restoring!! please help!
    Last edited by McManimal; 2010-09-03 at 12:49 PM. Reason: Automerged Doublepost

  2. #2
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    considering that you have uninstalled the last few apps that you installed and several others you said as well and the problem hasn't corrected itself I would think a restore will be your only option, you can wait for some more replies to see if anyone can offer more help but I'm pretty sure you will have restore

  3. #3
    the Rockapp, is buggy as hell. I recently had to do something like this. Rock did an update, and need to do a reboot. It rebooted to the apple logo and wouldn't move go past it.

    The only way for me to fix it was to do a restore, and re-jailbreak.

    if you need to get files off of the phone, like the theme you were working on, you should be able to, using iphone browser(windows only)
    Downloads - iphonebrowser - Project Hosting on Google Code

    other than that, your screwed, you need to do a restore.

    also dont use the Rockapp, stick with the stable apps store, Cydia

  4. #4
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    I guess restore is your only option.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •