Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Tmobile 3.1 5.11.07 want to go to ios 4

  1. #1
    Default Tmobile 3.1 5.11.07 want to go to ios 4
    Hello Friends,

    I own an iPhone 3GS (JB+unlocked) with the 3.1 firmware. I wish to update my device to iOS4 and unlock for Tmobile. I would appreciate if you could give me some directions.

    iPhone 3GS

    Version: 3.1 (7C144)
    Modem Firmware: 5.11.07
    Model: MC137LL

    Thanks!!!

  2. #2
    Same problem here. U can only update to 4.0.2 for which no JB is avaiable. I hope there is a way to selectively update to 4.0.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •