Results 1 to 20 of 20

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Wi Fi question after restore

  1. #1
    Default Wi Fi question after restore
    I have a 3GS. I went from 3.1.2 to 4.01 by using Shift/Restore. That went fine. Everything on phone works except I cant connect to Wi Fi. I used the backup in iTunes. Wi Fi won't connect. I don't know why. Could it be because I used the backup in iTunes? Any advice on how to fix Wi Fi. I already did the network reset. Should I do a shift/restore and start all over? thanks.

  2. #2
    To be safe, before you go through a full restore, you may want to try connecting to a friends/neighbor's wifi first. If it works there, than you know it is not the phone.

    Also, if you end up restoring, maybe, before restoring, complete restore (not from backup) and test it before restoring from backup and then again before JB.

    Just my two cents

    Also, you can try to reflash the baseband with bootneuter
    Last edited by y2kcurt; 2010-08-31 at 10:18 PM. Reason: Automerged Doublepost

  3. The Following User Says Thank You to y2kcurt For This Useful Post:

    Dubro (2010-09-01)

  4. #3
    Thats a good idea. I'll stop at Starbucks on the way home from work tonight and see if I can connect to their Wi-Fi. thanks

    I havn't Jailbroke it yet. I was first making sure everything on the phone works before I Jailbreak.

  5. #4
    If it's not jailbroken already and you set it up as a new device there is a bigger problem. you can only restore the device to 4.0.2 so you may want to wait for 4.1 (probably tomorrow) and hope there's a jailbreak. you may just want to update to 4.0.2 to see if wifi works since you cant restore to 4.0.1 anyway.

  6. #5
    I re-did it yesterday. I re-restored it using iTunes Shift/Restore and it restored to 4.0.1 And previously I did click "set up as new phone"

    I still cannot connect to my home Wi Fi. I drove up to a Starbucks and from my car it connected to their Wi Fi very quickly. So it must be something to do with my router. I have to figure that one out next. thanks

  7. #6
    Great have you changed anything with your router recently?
    You may want to just unplug and replug see if it goes back to normal.

  8. The Following User Says Thank You to korin125 For This Useful Post:

    Dubro (2010-09-02)

  9. #7
    I got my phone to connect to my wi-fi tonight. It was a bad password. My fault. Now I will leave 4.0.1 on for a couple of days and jailbreak this week end :-)))

  10. #8
    Hey Dubro,

    What was your exact Wifi Issue? Were you unable to see the wifi network or did it not connect? Was it giving you an error when it tried to connect?

    I am having the same problem. I used an old AT&T sim card to activate and its just not seeing my home network or any other one in fact. How did you jailbreak/unlock without the wifi? Did you use 3G?

    Where did you get the 4.0.1 Fw for iphone 3gs from. Can you send the link to me please as well?

    Thanks

  11. #9
    1) He was unable to connect due to a password issue.
    2) Not seeing it is a differrent problem completely,that would really require a restore
    3) Frirmwares are available on modmyi in downloads -> firmwares or on iPod, iPhone and iPad Firmware Download

  12. #10
    Thanks. I have tried restoring 4-5 times already but no luck. I tried downgrading to 3.1.3 or 3.1.2 but it gives me a 1015 error

    Any help would really be appreciated.

  13. #11
    Are you able to restore to 4.0.1?
    Can you see wifi on a fresh indtall?
    Can you jailbreak with jailbreakme?
    Can you see wifi after jailbreak?
    Activate, can you see wifi?
    Unlock, can you see wifi?

    Try all those in order to find out your problem
    If you can'r restore let me know.

  14. #12
    Thanks for your help.

    Yes, I can restore to 4.0.1

    No, I can't see wifi on fresh install. I assume by fresh install you mean putting the phone in DFU mode and then selecting the firmware I downloaded.

    I haven't gotten further since I don't have wifi so can't connect to internet to jailbreak. I need the unlock to be able to use another sim and use 3G data.

    Thanks

    Oh and another very interesting observation that has totally confused me. When I downgrade to OS 3.1.3 , I can suddenly see wifi!!! When I restore up to 4.0.1 again, its lost!

    This is weird. Please help me!
    Last edited by mlapse; 2010-09-04 at 03:02 AM. Reason: Automerged Doublepost

  15. #13
    Alright, when you restore you are setting up device as new?
    Can other devices see and connect to your router?

  16. #14
    Yes I am setting it up as a new phone each time. SHould I try setting up as an old one?

    I have another iphone (still on 3.1.2 my wife's and so i cant mess with it at all), an ipad, and 3 laptops all connecting to the network.

  17. #15
    I guess you might as well try restoring from a backup.
    You could also try resetting your router, and setting to a new channel.
    Is this an iPhone 3GS?

  18. #16
    Yes it is a 3GS. The thing is I live in a college where we have 3 networks around me. My other phone can see all three and this one can't. I tried updating firmware on router but its already current. I can reset and set to a new channel but I don't think that's it.

    The thing is that the wifi works as soon as I downgrade to 3.1.3.Wonder if anyone has experienced this issue yet. it seems to suggest an issue with the firmware. But then it would affect many more people than just me.

    Another point is that I'm not using the shsh but am redirecting to Cydia. I use the following IP - 74.208.10.249

    I don't know how this affects the upgrade but I hope the IP is correct.
    Last edited by mlapse; 2010-09-04 at 03:49 AM. Reason: Automerged Doublepost

  19. #17
    The best way to troubleshoot your wi fi is to go to somewhere like Starbucks where wi fi is free and see if you can connect. If you can then you know it's not your phone. If you can then you have a problem at home and you can start troubleshooting that situation. In my case I forgot my password. (i was sure that I knew it, but I was wrong!) So my first troubleshooting idea was to make a new password and see if that fixed it and it did.

  20. #18
    Thanks mate. I think I have figured out that the firmware 4.0 seems to not work the wifi while the firmware 3.1.3 seems to. Seems like its a phone problem

    I guess I'll be stuck on 3.1.3 unless someone can help me out.

  21. #19
    So a last thing, are you restoring to 4.0 or 4.0.1? If you have an option for both have you tried both?

  22. #20
    I tried with both - 4.0 and 4.0.1 - I see posts on Apple support where others seem to be experiencing Wifi issues.

    I can't believe several devices lates, Apple is still having issues with Wifi. the Ipad was such an agonizing issue. Now this!

    If anyone can figure out something, please let me know.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •