Page 1 of 2 12 LastLast
Results 1 to 20 of 27

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Is it too late for me? I'm on 3.1.2

  1. #1
    Question Is it too late for me? I'm on 3.1.2
    My iPhone is on 3.1.2 with new bootrom. What's the best way for me to JB and which ver. firmware can I go to. I've been reading and reading for a few days and am confused. thanks

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    modmyi.com/forums/general/726511-iphones-only-you-jailbreakable.html

    This will help you determine whether you can upgrade or not and what you can JB with.

    If you cant move up after assessing this info, stay on 3.1.2 and use jailbreakme to jailbreak. Youll need an official carrier's SIM to use jailbreakme.

    If you choose Blackra1n which does not need the SIM, youll have a tethered JB which Im sure you want to avoid (everytime your phone shuts off or reboots youll have to run Blackra1n on your comp to get it working again). So Id stay away from Blackra1n if I were you.

  3. The Following User Says Thank You to i.Annie For This Useful Post:

    Dubro (2010-08-29)

  4. #3
    My iPhone is a Part of Me Trooper Sam's Avatar
    Join Date
    Jul 2010
    Location
    Somewhere in California
    Posts
    503
    Thanks
    51
    Thanked 78 Times in 62 Posts

    Spirit or jailbreakme will do nicely, as both provide a non-tethered jailbreak.

  5. The Following User Says Thank You to Trooper Sam For This Useful Post:

    Dubro (2010-08-29)

  6. #4
    Thanks for the Info Guide!! Below at the end is what it told me. I have some questions:

    I used tiny umbrella to save the SHSH's (i'm on 3.1.2, never JB'd) So I guess that means if I ever want to restore I will restore to 3.1.2 only. Correct?

    Should I use Jailbreakme2 now? And if I do can I upgrade to 4.0.1? Or am I stuck on 3.1.2? (I want to be at the highest firmware that will allow a JB and an unlock.)

    Do I upgrade now to 4.0.1 then use Jailbreakme2? or use Jailbreakme2 then upgrade to 4.0.1?

    note;(I don't want a tethered JB)
    thanks

    Phone 3GS (new boot): Need SHSHs for all firmwares to restore to. The only difference with new boot devices compared to old boot is that you cannot use custom firmwares at all. Jailbreak processes are the same otherwise. Blackra1n on 3.1.2 will cause a tethered jailbreak so the other methods should be used.

    Note**Jailbreakme and Spirit require official carrier's SIM (ie US phone requires AT&T SIM) to activate before jailbreak can work.

  7. #5
    Folks I downgraded from 4.0.2 to 3.1.2, i have baseband 05.13.04. I successfully jailbroke it using blackra1n. I have power cycled the phone a number of times and have not had to tether it afterwards.

  8. #6
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    Quote Originally Posted by GavinH View Post
    Folks I downgraded from 4.0.2 to 3.1.2, i have baseband 05.13.04. I successfully jailbroke it using blackra1n. I have power cycled the phone a number of times and have not had to tether it afterwards.
    is there a problem you need help with?

  9. #7
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Quote Originally Posted by Dubro View Post
    Thanks for the Info Guide!! Below at the end is what it told me. I have some questions:

    I used tiny umbrella to save the SHSH's (i'm on 3.1.2, never JB'd) So I guess that means if I ever want to restore I will restore to 3.1.2 only. Correct?

    Should I use Jailbreakme2 now? And if I do can I upgrade to 4.0.1? Or am I stuck on 3.1.2? (I want to be at the highest firmware that will allow a JB and an unlock.)

    Do I upgrade now to 4.0.1 then use Jailbreakme2? or use Jailbreakme2 then upgrade to 4.0.1?

    note;(I don't want a tethered JB)
    thanks

    Phone 3GS (new boot): Need SHSHs for all firmwares to restore to. The only difference with new boot devices compared to old boot is that you cannot use custom firmwares at all. Jailbreak processes are the same otherwise. Blackra1n on 3.1.2 will cause a tethered jailbreak so the other methods should be used.

    Note**Jailbreakme and Spirit require official carrier's SIM (ie US phone requires AT&T SIM) to activate before jailbreak can work.
    Um...I think you misunderstood. With new bootrom, and you probably dont have your SHSHs, you cant upgrade or restore. You have to stay on 3.1.2 to jailbreak. If you want it untethered, youll use Spirit or jailbreakme to jailbreak. Both require you to get an official carrier's SIM.

    Edit: when did you save your SHSHs? Check TinyUmbrella by clicking "Display SHSH" to see if it saved any SHSHs. If it doesnt say you have any SHSHs, you probably tried saving too late and missed your chance.
    Last edited by i.Annie; 2010-08-29 at 10:17 PM. Reason: Automerged Doublepost

  10. The Following User Says Thank You to i.Annie For This Useful Post:

    Dubro (2010-08-30)

  11. #8
    I backed up my SHSH's on July 27th. I checked tiny umbrella and it said "The following device can be restored safely:
    iPhone 3GS 4.0.1 (8A306)- 1202356484509"

    I have a 3GS. I'm with AT&T since I bought the phone from them. It's at 3.1.2, never JB'd It has the new boot rom.
    I want an untethered JB but need help with a plan of attack; Should I let it upgrade to 4.0.1? Or should I jail break it first using jailbrekme2.com then let it upgrade itself to 4.0.1? thanks
    (I've used tiny umbrella on July 27th to save the SHSH's)

  12. #9
    Livin the iPhone Life jkmonkey's Avatar
    Join Date
    Mar 2010
    Location
    Upstate NY
    Posts
    1,433
    Thanks
    67
    Thanked 254 Times in 245 Posts

    Since you have shsh's for 4.0.1 upgrade to that then use jailbreakme.

  13. The Following User Says Thank You to jkmonkey For This Useful Post:

    Dubro (2010-08-30)

  14. #10
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    You can stay on 3.1.2 or go to 4.0.1 your choice.

    In the Guides section here on MMi you can find a guide for restoring with SHSHs for 3GS.

  15. The Following User Says Thank You to i.Annie For This Useful Post:

    Dubro (2010-08-30)

  16. #11
    How do I upgrade to 4.0.1? Just use iTunes? I definitely don't want iTunes to take it to 4.0.2! thanks

  17. #12
    Download tinyumbrella and start TSS server. Shift-click restore to 4.0.1 downloaded from iPod, iPhone and iPad Firmware Download.

  18. The Following User Says Thank You to korin125 For This Useful Post:

    Dubro (2010-08-30)

  19. #13
    So after I use tiny umbrella and upgrade to 4.0.1 I can check it out for a couple of days and then jailbreak using jailbreakme2.com. correct?
    thanks you guys!

  20. #14
    Why check it out? Jailbreak away! A few minutes on stock firmware is long enough for me!!!

    P.S. I've never heard of jailbreakme2.com, only jailbreakme.com and jailbreakme.modmyi.com. Use either of those.

  21. The Following User Says Thank You to korin125 For This Useful Post:

    Dubro (2010-08-30)

  22. #15
    Yea, I don't know where I got jailbreakme2.com from. Weird. Thanks for the advice :-)

  23. #16
    I actually saw and article somewhere right when the jailbreak came out saying jailbreakme2.com and i thought "that's not right", lol.

  24. The Following User Says Thank You to korin125 For This Useful Post:

    Dubro (2010-08-30)

  25. #17
    I tried using tinyumbrella and I don't think I'm doing something correctly. I started the TSS Server in tinyumbrella. Then I went to iTunes and clicked on "dubro's iphone" I shift clicked on restore. Then it did not ask me where the file was located. It just started updating and said it would take about 6 minutes so I canceled it because it did not ask where the file was. Am I doing something wrong?
    PS The file that tinyumbrella backed up last month has the extension .shsh is that normal. Or should the extension be .ipsw? Also should I use the backup file from tinyumberlla or just download the restore file from the link you gave?
    Last edited by Dubro; 2010-08-30 at 08:36 AM.

  26. #18
    1) So you went to your phone page held shift and clicked restore, and you didn't get to choose?

    2) You are backing up and SHSH file, nothing more.

    3) You restore to a firmware, downloaded from the website I listed.

  27. The Following User Says Thank You to korin125 For This Useful Post:

    Dubro (2010-08-30)

  28. #19
    1) I went to phone page held shift clicked restore and did not get to choose.

    2) I am backing up and have my SHSH file from tinyumbrella saved on the pc.

    3) I save the file from the website you listed to a folder on the pc.

    Do you have to be in DFU mode? Because I'm just hooking up the phone to the pc then iTunes comes up automatically and does a backup. When it's done I then I tried Shift restore. A message comes up and says

    "Are you sure you want to restore the iPhone?. "Dubro's iPhone" to it's factory settings? All of your contacts an data will be erased. And the newest version of the iPhone software will be installed."

    Then there is a button you can click on "restore and update"

    thanks

    Some uccess but a new error: Please help

    I went to a different PC. Installed iTunes. Hit Shift/Restore. Now it let me choose the file! Chose the file from the link that I saved. All went fine until the end. Got an error message:

    "An unknown error occurred. Upgrade could not be completed. Error 3002"

    In TinyUmbrella under advanced options, where it says "Request from; should it be the Cydia server or the Apple server?

    Any ideas how to fix this? thanks
    Last edited by Dubro; 2010-08-30 at 07:25 PM. Reason: Automerged Doublepost

  29. #20
    Drinks the Kool Aid Captinsmooth's Avatar
    Join Date
    Mar 2010
    Location
    New York
    Posts
    1,322
    Thanks
    131
    Thanked 351 Times in 199 Posts

    Quote Originally Posted by Dubro View Post
    1) I went to phone page held shift clicked restore and did not get to choose.

    2) I am backing up and have my SHSH file from tinyumbrella saved on the pc.

    3) I save the file from the website you listed to a folder on the pc.

    Do you have to be in DFU mode? Because I'm just hooking up the phone to the pc then iTunes comes up automatically and does a backup. When it's done I then I tried Shift restore. A message comes up and says

    "Are you sure you want to restore the iPhone?. "Dubro's iPhone" to it's factory settings? All of your contacts an data will be erased. And the newest version of the iPhone software will be installed."

    Then there is a button you can click on "restore and update"

    thanks

    Some uccess but a new error: Please help

    I went to a different PC. Installed iTunes. Hit Shift/Restore. Now it let me choose the file! Chose the file from the link that I saved. All went fine until the end. Got an error message:

    "An unknown error occurred. Upgrade could not be completed. Error 3002"

    In TinyUmbrella under advanced options, where it says "Request from; should it be the Cydia server or the Apple server?

    Any ideas how to fix this? thanks

    When you start TinyUmbrella make sure I tunes is closed. Also Right click on Tu when you go to open it and choose run as admin. Then direct it to cydia and run the TSS sever. Then start Itunes and do the shift restore to choose 4.0.1
    This post infers no rights and is provided as is.

    Click here to follow me on twitter

  30. The Following User Says Thank You to Captinsmooth For This Useful Post:

    Dubro (2010-08-31)

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •