Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Stuck in recovery loop on 3Gs 4.0.1

  1. #1
    Default Stuck in recovery loop on 3Gs 4.0.1
    A few days ago I was running 3.1.3 jailbroken with Spirit, until I decided I wanted to upgrade. I downloaded the ipsw file from iClarified - iPhone - Where To Download iPhone Firmware Files From
    and used the "Restore" option. All went well so far. I was running 4.0.1 and the first thing I did was visit Jailbreakme.com to jailbreak. After jailbreaking, I had issues with Springboard and several apps crashing. This is where I am stuck

    In Cydia I have SHSHs on file for 3.1.3, 4.0, and 4.0.1. My phone is stuck in the recovery loop, and I have looked around for solutions but have not been successful. I have tried restoring several times to 4.0.1, the same ipsw file I downloaded when I upgraded.

    I have edited the hosts file to redirect iTunes to Cydia's server. Here's the hosts file, please tell me if it's wrong?

    # Copyright (c) 1993-1999 Microsoft Corp.
    #
    # This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
    #
    # This file contains the mappings of IP addresses to host names. Each
    # entry should be kept on an individual line. The IP address should
    # be placed in the first column followed by the corresponding host name.
    # The IP address and the host name should be separated by at least one
    # space.
    #
    # Additionally, comments (such as these) may be inserted on individual
    # lines or following the machine name denoted by a '#' symbol.
    #
    # For example:
    #
    # 102.54.94.97 rhino.acme.com # source server
    # 38.25.63.10 x.acme.com # x client host

    # 127.0.0.1 localhost
    74.208.10.249 gs.apple.com

    I have tried restoring while in DFU mode. The restore process would get stuck just over halfway finished, whether starting in DFU or in recovery mode.

    Sometimes I would get iTunes error codes 1611 (hardware error) or 3194 (iTunes cannot connect to the gs.apple.com server)

    Any ideas? I have taken my phone to the Apple store once before for the same reason, but this was getting stuck in the recovery loop from 3.1.2 to 3.1.3. I was fine with ending up with 3.1.3, because Spirit was a much better jailbreak than Blackra1n.

    I'm afraid I won't be so lucky this time; according to the Dev Team Blog, there will not be a jailbreak for 4.0.2. I HAVE NOT tried doing a regular restore, which would upgrade my phone to 4.0.2. I will try that as a last resort. Thanks for any help!

  2. #2
    Green Apple
    Join Date
    Aug 2010
    Location
    Australia
    Posts
    34
    Thanks
    6
    Thanked 1 Time in 1 Post
    I dont see why you would need to downgrade just use RecBoot (google it) and make sure you have Libusb installed

  3. #3
    There are a lot of guides out there for restoring a phone to old firmware. Find one that uses tiny umbrella rather modding the hosts file, it's much easier.

    When you're done, you can use tiny umbrella to kick you out of recovery mode.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •