Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Restoring without updating

  1. #1
    Default Restoring without updating
    Any idea how I would be able to restore my iphone to the version it's already running instead of doing the restore/update that apple wants me to do?

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Which phone and what firmware?

    2G/3G = shift+restore to any 3.1.x firmware without SHSHs.

    3G only = need SHSHs for iOS 4 and 4.0.1

    3GS new boot = needs SHSHs for all firmware versions.

    3GS old boot = shift+restore to custom fw for any firmware version. Can be created via PwnageTool (Mac) or Sn0wbreeze.

    iPhone 4 = need SHSHs for 4.0 and 4.0.1 to restore.

  3. #3
    3gs and I'm pretty sure it's new boot. I have shsh's for the version I'm running but how do I use them?
    Last edited by robertr1; 2010-08-27 at 01:59 AM.

  4. #4
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    modmyi.com/guides/restore-iphone-3gs-3-1-2-using-shshs-file-cydia-windows/

  5. The Following User Says Thank You to i.Annie For This Useful Post:

    robertr1 (2010-08-27)

  6. #5
    Quote Originally Posted by robertr1 View Post
    3gs and I'm pretty sure it's new boot. I have shsh's for the version I'm running but how do I use them?

    EDIT: I just saved them with tiny umbrella but it's saying that it saved 4.0.2..... Cydia says I have shsh for 4.0 and 4.0.1 on file though. Tinyumbrella also says it's on 4.0.1. Why does it say it saved 4.0.2?
    You should be fine.
    Your 3GS is running 4.0.1

    Umbrella can't save 4.0.1 SHSH anymore because Apple won't sign them, so it saved a 4.0.2 SHSH instead. That's what its supposed to do.

    Cydia already saved SHSH for 4.0 and 4.0.1 so you should be able to restore to either of those using the guide Anniex423 just posted.

    The way it works, you CAN'T downgrade to an earlier version after Apple has stopped signing it, unless you already saved a signature from before. The ones you just saved today won't help to downgrade to an earlier version, but you previously saved 4.0.0 and 4.0.1 so everything is good.
    Last edited by raduga; 2010-08-27 at 01:53 AM.

  7. The Following User Says Thank You to raduga For This Useful Post:

    robertr1 (2010-08-27)

  8. #6
    Something's wrong. It gave me a -9800 error after restoring and now absolutely nothing works. All I can do is go back into dfu mode.

    EDIT: Ok tried it again and it worked. I have no idea what went wrong last time but at least it worked the second time thanks.
    Last edited by robertr1; 2010-08-27 at 03:12 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •