Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Wifi connects but no internet connection on jailbroken and unlocked 3GS 4.0.1

  1. #1
    Default Wifi connects but no internet connection on jailbroken and unlocked 3GS 4.0.1
    Hello!

    One month ago I bought a jailbroken and unlocked 3GS with 3.1.3 and everything was working just perfect. Then I decided to upgrade it to 4.0.1 and then to jailbrake it again through jailbrakeme.com. Since that moment I have noticed problems with wifi/internet connection. I can connect perfectly to the router, but I have no internet connection... I should say that it is quite strange, since from time to time I can get online... but after some hours it doesn't work again.

    I tried to restore my phone network settings but it doesn't work.

    Thank you all in advance!

    Greetings!

  2. #2
    I've had the same problem too although it some occurs with EDGE/3G as well.

    What I do to temporarily fix it is to do a hard reset on the Phone (Holding Home+Lock button for 10 seconds).

    I really refrain from doing this alot as I believe too many hard resets will be harmful to the device in the long run, so I'm looking for a permanent solution too :/

  3. #3

  4. #4
    Actually the hard reset worked. I almost one week without a failure since I did it!

    Greetings!

  5. #5
    Banned
    Join Date
    Aug 2010
    Location
    New Zealand
    Posts
    279
    Thanks
    1
    Thanked 7 Times in 7 Posts

    i had this same issue on my jailbroken ipod touch. I reconfigured tcp ip and ever specified a DNS server. that seemed to work for me? also try clicking "forget this network" and search again.

    hope this helps

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •