Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How should I jailbreak and upgrade this OLD firmware (3.0) 2G & 3G

  1. #1
    Default How should I jailbreak and upgrade this OLD firmware (3.0) 2G & 3G
    Two phones, not sure which firmware SHSHs matter on, I would guess they are completely irrelevant on the iPhone 2G since you can't go higher that 3.1.3.

    iPhone 2G
    •3.0, Jailbroken and Unlocked
    •I believe it was done with redsn0w or PwnageTool
    •04.05.04_G don't think that matters with the current unlocks

    iPhone 3G
    •3.0 Never jailbroken (no SHSHs)
    •Needs to be unlocked
    •yep, I know I'll be stuck with only 4.0.2 SHSHs but can anything be applied since it's still on 3.0 before the blobs mattered)?
    04.02.08
    •Can I go directly to 4.0.2 and use redsn0w?

    What should I do on each? Which firmware? Which jailbreak/unlock?

    Thanks guys

  2. #2
    My iPhone is a Part of Me Trooper Sam's Avatar
    Join Date
    Jul 2010
    Location
    Somewhere in California
    Posts
    503
    Thanks
    51
    Thanked 78 Times in 62 Posts

    Upgrade both to 3.1.3, then jailbreak with jailbreakme.com, then use Saurik's PDF patch. Unlock with ultrasn0w, and have a great day.

    Oh, and don't worry about SHSH for the 3G. They're only needed for 4.0 and above, and you can avoid that trouble by using iTunes versions before 9.2. Don't use 4.0 or above on a 3G, you won't much like the results.

  3. #3
    And I think the only unlock for iPhone 2G is BootNeuter

  4. #4
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    the phones will have to be activated to use jailbreakme, so unless you have an official carrier sim laying around it will have to be an activated 3.1.3 firmware for the 2G followed by ultrasn0w and redsn0w for the 3G followed by an activated custom 3.1.3 firmware followed by ultrasn0w since both phones need to be unlocked

    you can also restore to official 3.1.3 on the 2G and use redsn0w to activate/jailbreak/unlock all at the same time
    Last edited by j3st3r; 2010-08-23 at 03:32 AM.

  5. #5
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    ^ just to clarify, for 3.1.3 youll need Redsn0w 0.9.4

    2G unlock is with BootNeuter. I dont believe Ultrasn0w works on its baseband?

    2G try a custom fw unless you dont find it difficult to find the 3.9 and 4.6 bootloader binary files which Redsn0w needs to proceed to jailbreak.

  6. The Following User Says Thank You to i.Annie For This Useful Post:

    j3st3r (2010-08-23)

  7. #6
    Retired Moderator j3st3r's Avatar
    Join Date
    Mar 2008
    Location
    Louisiana
    Posts
    2,447
    Thanks
    42
    Thanked 405 Times in 395 Posts

    thanks for the clarification, I have never had to unlock so I wasn't 100% on the 2G unlock

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •