Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Push Notifications Not Working on iPhone 4??

  1. #1
    What's Jailbreak?
    Join Date
    Sep 2009
    Location
    Edmonton, AB, Canada
    Posts
    14
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Exclamation Push Notifications Not Working on iPhone 4??
    I'm not sure if I'm having problems on my phone or if it's a server problem.

    Me and a friend both have 32GB iPhone 4s, but with 4.0.1 installed and both jailbroken using jailbreakme.com. We downloaded and installed the free versions of both Words With Friends and Chess With Friends from the App Store. These games work with push notifications to let you know when your opponent is done and it's your turn. Words seems to work fine; push notifications comes in no problem and they are quite quick. However, we are getting 0 push notifications from the Chess game. These games are both written by the same developer. After browsing around on their site, they have an announcements page that lets people know if they are having any server issues. Nothing is posted so I'm assuming their server is running fine.

    So then that led me to believe that maybe it's a problem with being jailbroken. Has anyone experience problems with push notifications not working on a jailbroken iPhone 4? If so, is there some sort of fix available?

    We are NOT "hacktivated" (if it's even possible on the iPhone 4), I have a factory unlocked iPhone and he is legitimately activated through Rogers (Canadian carrier).

    Thanks for the help!

  2. #2
    Same problem with me. It appears something is broken when jailbreaking. I don't know how to fix it though, anyone?

  3. #3
    I had this problem last week, I used Push Donor and it fixed my push notifications. All, except for Chess. Somehow that push notification isn't working.

  4. #4
    I do not think it's JB issue as I can see push for other apps.

  5. #5
    ya push for me works 80-90% of the time, but then i get a new email or something important on facebook and it doesn't ring, kinda annoying having to check myself. I think it is the jailbreak as I didn't have this problem whatsoever without jailbreak, a minor setback i guess.

  6. #6
    Quote Originally Posted by piston597 View Post
    ya push for me works 80-90% of the time, but then i get a new email or something important on facebook and it doesn't ring, kinda annoying having to check myself. I think it is the jailbreak as I didn't have this problem whatsoever without jailbreak, a minor setback i guess.
    I am not sure about the system wide push but "Chess with Friends" push does not work 100%.

    This is the only app I really care about for Push, as of now, and it's sad to see that the push for it does not work.

  7. #7
    go to settings then notifications see if it the chess one is on off or on, maybe thats the problem?

  8. #8
    Quote Originally Posted by piston597 View Post
    go to settings then notifications see if it the chess one is on off or on, maybe thats the problem?
    I really appreciated your response but I have already checked that many times. Even I tried changing the push options (on/off) to see if it works.

  9. #9
    Quote Originally Posted by salivgn View Post
    I really appreciated your response but I have already checked that many times. Even I tried changing the push options (on/off) to see if it works.
    I think it's a bug w/ the "Chess w/ Friends" app. I have push problems with that app as well, and this was even before I JB.

    All my other apps (messages, facebook, etc.) all push fine.

    w00master

  10. #10
    Quote Originally Posted by w00master View Post
    I think it's a bug w/ the "Chess w/ Friends" app. I have push problems with that app as well, and this was even before I JB.

    All my other apps (messages, facebook, etc.) all push fine.

    w00master
    Cool. Yeah, it could be...

    But the push was working for that app until few days back.

  11. #11
    I lost all my push notifications and even push MobileMe mail but after trying everything a simple resync with iTunes fixed it instantly.

    Sounds like if it's just the one app that's bring problematic it's probably just that one apps fault, not your phone

  12. #12
    Quote Originally Posted by smeeshum View Post
    I lost all my push notifications and even push MobileMe mail but after trying everything a simple resync with iTunes fixed it instantly.

    Sounds like if it's just the one app that's bring problematic it's probably just that one apps fault, not your phone
    Yeah seems like it's just one app.

  13. #13
    Is anyone else having issues with push notifications? I'm on iPhone 4 4.0.1 JB & Official Carrier. I have to keep resetting my Network Settings and Resyncing with iTunes as every few days my push notifications just stop responding.

    I finally bit the bullet the other day and spent an entire evening Restoring my iPhone and putting back all it's contents bit by bit as a New Phone. I though it had worked but then today they stopped working again.

    I find it's mostly on wifi they stop. I read an article on Apples own support forums that some people have had this issue on secured "work" wireless networks and have fixed it by using an Open DNS in there wifi settings. I tried this too and it appeared to help for a bit but then once again stopped working.

    I have also requested a new Router from my ISP to see if it solves the problem but after performing a full factory reset on my original router and that not helping I have little hope a new one will solve it.

    Anyone out there at all have the same issue? If so what JB apps are you sporting? Anyone know of a fix or what part of the JB could be causing it?

    Any help would be much appreciated guys.

  14. #14
    Quote Originally Posted by smeeshum View Post
    Is anyone else having issues with push notifications? I'm on iPhone 4 4.0.1 JB & Official Carrier. I have to keep resetting my Network Settings and Resyncing with iTunes as every few days my push notifications just stop responding.

    I finally bit the bullet the other day and spent an entire evening Restoring my iPhone and putting back all it's contents bit by bit as a New Phone. I though it had worked but then today they stopped working again.

    I find it's mostly on wifi they stop. I read an article on Apples own support forums that some people have had this issue on secured "work" wireless networks and have fixed it by using an Open DNS in there wifi settings. I tried this too and it appeared to help for a bit but then once again stopped working.

    I have also requested a new Router from my ISP to see if it solves the problem but after performing a full factory reset on my original router and that not helping I have little hope a new one will solve it.

    Anyone out there at all have the same issue? If so what JB apps are you sporting? Anyone know of a fix or what part of the JB could be causing it?

    Any help would be much appreciated guys.
    I believe this is a bug w/ Words with Friends & Chess with Friends. If you look above your post, you'll notice peeps saying the same thing about those apps. I've not noticed this with other apps that I have: BeeJive, Facebook, etc. It's only Chess with Friends that I've noticed this issue with.

    w00master

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •