Hi folks,

I'm having a really hard time since I've jailbroken my phone and was hoping someone might have an answer or solution on this. When the JB was originally released, I jailbroke my phone... then installed WinterBoard. After rebooting/respring, my phone crapped out on me (I lost my cellular signal, data and Wifi). I turned the phone off for the night and when I woke up in the morning, it was working normal again.

I then tried to install Infinifolders, same thing happened... I then restored my phone, re-jailbroke it. Tried installing Infinifolders again - bang! My phone crapped out on me again. Repeated this process and same thing, my phone keeps crapping out on me.

I turned it off last night and it was working again this morning. I tried installing a Cydia tweek to change my AT&T logo and then closed Cydia. Well the logo didn't appear on my phone, but did appear once I opened Cydia, so I turned off my phone and when I reloaded, I received this message:



I have already restored/jailbroke my phone three times... I've tried hard boot, restoring network, etc and nothing works unless I turn off the phone for several hours. I jailbroke my daughter's iPod with no problems, so I'm totally baffled...

I have a 3GS running iOS 4.0.1 (previously downgraded to iOS4, but had the same problem).

Any help would be SO great, tks!!!