Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: How screwed am I? I jailbroke iOS4 3Gs that came packaged with iOS4

  1. #1
    Default How screwed am I? I jailbroke iOS4 3Gs that came packaged with iOS4
    As the title says, I jailbroke an iOS4 3Gs which had iOS4 installed out of the box (using jailbreakme.com), so there is no SHSH backup of it ever with 3.x firmware (I didn't know about this until I started to have problems). I really need to know what I'm up against. I am obviously getting the 3014 error when I try to do anything "official" with the firmware (Restore/update etc), and this is despite adding 74.208.10.249 gs.apple.com to the hosts file. So what I need to know is

    A) Is there anything I can do now? Should I be able to restore the unit? If I should, what am I doing wrong?

    B) If I can't do anything now, is it just a case of waiting. This is a problem that will be solved?

    C) I'm a total idiot, I should not be allowed near a remote control, let alone a flippin iPhone. No, your iPhone is gone mate, dead as dead can be. You will never be able to authorise it so you are stuck with it in the situation it's in now.

    Just to reiterate, my steps were
    1- Turned on phone
    2- Backed up from old 3G phone through iTunes
    3- went to jailbreakme.com and applied the jailbreak
    4- Installed Rock
    5- Backup up from my rock
    6- Started to get errors on iPhone (Always in safe mode)
    7- Tried to restore phone back to 3.1.2, then to any version to firmware but kept getting 3014 error

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Safe mode was because some of the programs that were installed from "back-up" are not compatible on 4.0 yet. When going from major firmware (3.0) to major firmware (4.0) you NEVER do any sort of restore from backup. What you need to do is put your phone in DFU or recovery and restore to 4.0.1.. then start all over.

  3. #3
    when you add the hosts file I had to restart my computer to take affect.
    like poseidon79 said. some things are not ios4 compatible. never restore from a backup on a iphone when you jailbreak.

    but it in dfu mode. shift restore select the 4.0.1 file then as fresh back up the iphone 4 with nothing on it ( make sure u save ur contacts 1st ) then go to jailbreakme.com and try again good luck

  4. #4
    legends! Right, so just to be 100% sure (I am really scared of screwing myself up even more), what I need to do is install iOS4.0.1, then revert to iOS 4.0 (and the reason I can do this is cos the SHSH is saved on Cydia), then jailbreak again.

    Allot of people seem to have problems with the jailbreakme method, is there a method like sn0wbreeze or redsn0w (ie done locally rather then online)?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •