Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Apple logo is stuck on boot up. 3GS MB717, 4.0.1 - HELP :)

  1. #1
    Default Apple logo is stuck on boot up. 3GS MB717, 4.0.1 - HELP :)
    Hi all,

    I am having some random problems with my iphone.

    It was previously on 4.0 but I missed the slot to save shsh so I only got the 4.0.1 which is a bummer.. :I

    The firmware upgrade goes through successfully and fully activated in iTunes, however, the actual logo remains on the screen. Tried re-upgrading while in DFU mode or recovery, made no difference. Tried using a different computer.. once again. same thing.

    One weird thing is.. When I upgraded to ios 4.0.1, for some reason the bootrom was not updated (its still mb717)? I didnt try to jailbreak. Just to upgrade the original apple firmware.

    Any suggestions how to get through this? any help is appreciated.

    Thanks,
    CJ

    Does anybody have a MAC who could perhaps create a custom 4.0.1 firmware? I couldnt find any...
    Last edited by chenlevi21; 2010-07-30 at 09:04 AM. Reason: Automerged Doublepost

  2. #2
    My iPhone is a Part of Me
    Join Date
    Apr 2010
    Location
    N. Ireland
    Posts
    649
    Thanks
    10
    Thanked 81 Times in 75 Posts

    MB/MC is not your bootrom, it's your serial number and can be used to identify bootrom's on iPod Touch's NOT 3GS.

    Also, to jailbreak on iOS4.0 or 4.0.1 you need to start on 3.1.3/3.1.2 AND have old bootrom, so you need to downgrade first, do you have SHSH to allow you to do this? Also use iDetector to determine bootrom.

  3. #3
    Hey will01, thank you for pointing this out.

    I used iDetector to determine my bootrom and it indicated Old Bootrom (thats why I mentioned it in the first place).

    The point that I was trying to make was that I wasnt actually trying to jailbreak my iphone, only to upgrade the firmware to 4.0.1 but for some strange reason after the completion of restore(successful!), the iphone gets into a loop where it just has the spinning wheel and restarts itself. Trying restoring the device while in DFU as well as recovery with no joy.

    Not sure why so I was hoping I could get some help ...

    Any ideas/suggestions?

    Cheers,
    CJ

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •