Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Jailbreak/Unlock new iPhone 3GS

  1. #1
    Default Jailbreak/Unlock new iPhone 3GS
    Sorry for my ignorance, I'm a BlackBerry guy so this is all new to me, but basically I've just purchased a new iPhone 3GS that is on Fido, and I need to unlock it to use on Telus.

    The phone is on 3.0 firmware with 05.11.07 band.

    From what I've found in my research so far, the highest version that has a jailbreak/unlock is 3.1.3. The problem I'm running into is that iTunes only allows you to upgrade to the latest version (4.0.1) which doesn't have a jailbreak/unlock right now. I've downloaded the ispw files for 3.1.3 but I'm not able to upgrade to it from 3.0 through iTunes - it gives me an error.

    As far as I can tell, it's because I don't have the "signatures" or SHSH codes or something for it.

    I think I'm hooped and my only option is to wait for a jailbreak/unlock for 4.0.1 and upgrade to that and jailbreak/unlock it at that time.

    I'm hoping you guys might have a solution that might work for me now, but I'm doubtful. Any help would be appreciated.

  2. #2
    ok this is a simple straight forward solution


    Download redsn0w 0.8
    get the 3gs 3.0 firmware from google...google iphone firmware..first link

    run redsnow ..follow instructions guaranteed to work

    tips on putting into dfu mode=hold power and home for 15 secs,leave power and keep holding home for 10 secs as soon as u hear that plugging in sound on ur computer let it go!...this is easier then the way redsn0w does it


    then to unlock go to cydia...manage ..edit and add source...add this "repo666.ultrasn0w.com" thats it ...then go to search look for ultrasn... when u find it click and install it and when your phone boots it should be unlocked
    DONE!!100% should work

    just click thanks if it works...

  3. #3
    You need to find out a tool to JB at 3.0 before you can use custom firmware. It's too far back for me. It will be possible though.

    Try this:
    http://modmyi.com/forums/iphone-news...w-windows.html

    Once you've JB on 3.0 you can use custom firmware to go to any OS you want by using custom firmware from snowbreeze (win) or pwnagetool (mac). Then unlock with ultrasnow. This includes 4.0 OS.

  4. #4
    Quote Originally Posted by westonben View Post
    Once you've JB on 3.0 you can use custom firmware to go to any OS you want by using custom firmware from snowbreeze (win) or pwnagetool (mac). Then unlock with ultrasnow. This includes 4.0 OS.
    if u want to go to 4.0 after the unlock u should do that...but i say jus run it on 3.0 until a jb comes out for 4.0 ...up to u

  5. #5
    My iPhone is a Part of Me
    Join Date
    Apr 2010
    Location
    N. Ireland
    Posts
    649
    Thanks
    10
    Thanked 81 Times in 75 Posts

    Which error did you get? That BB/FW combo is wrong so it must have been on a newer FW, namely 3.1.2 to get 5.11.07 BB, it must have then been downgraded to 3.0. So it must have SHSH saved for 3.0 at least. May be worth checking with tiny umbrella.

    Either way, JB with redsn0w 0.8. Then cook a custom 4.0 IPSW (4.0.1 provides nothing of value to 3gs) and restore to that. I myself stayed on 3.1.3 however as I found 4.0 to be crap for JBer's as only a handful of apps work.

  6. #6
    Oops, I just checked and it's 3.1 firmware, not 3.0.

    But it's not 3.1.2 for sure.

    What do you guys mean by cooking a custom 4.0 ISPW? How do I do that? The error was 3194.



    Also, I downloaded redsn0w 0.8 and downloaded the 3.1 ISPW. I went to use redsn0w and it says it was unable to recognize specified ISPW. This is frustrating!
    Last edited by anarchy83; 2010-07-30 at 03:40 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •