Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Can't Restore from Backup. Can't Restore or Update Firmware. Screwed.

  1. #1
    Unhappy Can't Restore from Backup. Can't Restore or Update Firmware. Screwed.
    I had enough of the crappy performance I was getting when using 4.0 on my iPhone 3G, so I decided to downgrade to 3.1.2.

    Not realising I couldn't restore from the backup I created before downgrading, I followed this guide onto how to make this work by simply changing the build number and firmware version within the 'Info.plist' file using Notepad.

    I restarted iTunes and tried restoring from backup again, but this time received the following error message, 'iTunes could not restore the iPhone because a session could not be started with the iPhone'.

    After finding no remedy to fix the problem by Googling the error message, I then decided to just go back to 4.0 for now and try downgrading with a workable backup tomorrow. Can't remember if I restore or upgrade but I tried both and got different error messages (2002 and 3194). Also tried to restore in DFU mode to 4.0, got error 21 and I even tried 3.1.2 again just to see if it would restore using the firmware I'm already using..same error message. -_-


    So basically, I can't restore from backup and can't restore or update the firmware. Also, yes I have the SHSH blobs on file with Cydia and have saved what is needed to contact Saurik's server in the hosts file.

    Any help would be greatly appreciated, thank you.

  2. #2
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Download the 3.1.x ipsw (whichever you have your SHSH saved).

    Shift+restore to it. You should get error 1015 at the end, if you didnt get that error try again until you get error 1015.

    Get TinyUmbrella. Load it up and select "kick device out of recovery mode" and it should do just as it says. Let your phone reboot.

    Get Redsn0w 0.9.4 (not any other version) and run it. Despite if you restored to 3.1.3, you should use the 3.1.2 ipsw on Redsn0w or Redsn0w wont read it. Same with restoring to 3.1.2, use the 3.1.2 ipsw.

    If needed to unlock, install Ultrasn0w via Cydia (it should already be there so no need to add any repos).

    Good luck and keep me posted.

    Btw I was using iTunes 9.2 (but not the latest version, the version before the 4.0.1 update).
    Last edited by i.Annie; 2010-07-29 at 05:44 AM. Reason: Automerged Doublepost

  3. #3
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    ^^^ Note: The iPhone 3G does NOT require saved SHSH files for 3.x, only for 4.0 and above.

  4. #4
    I've done a few things to the phone and downloaded new firmwares to install... I didn't try the methods one by one so I don't know what went wrong before but iTunes suddenly lets me install 4.0! Right..so that's half of the problem solved.

    The backup I mentioned in the previous post won't work even though I edited the 'Info.plist' file back to having the correct build number and firmware version. iTunes says it's applying the backup but with it taking about 5 seconds to do it in when it's over 300mb..and the fact the address book is blank after rebooting..what went wrong? I'm very worried the backup has been corrupt, it's the only backup that hasn't got a timestamp on it when choosing which backup to restore from.

    If it has been corrupted, surely there is someway of getting the data from it and put it into a new one to restore from? Or a program that can read it? Really regret doing this, I really don't want to lose all my numbers and texts I've had saved over the years.

    Thanks for the help so far, any future contributions would be extremely appreciated. Cheers.

  5. #5
    My iPhone is a Part of Me
    Join Date
    Apr 2010
    Location
    N. Ireland
    Posts
    649
    Thanks
    10
    Thanked 81 Times in 75 Posts

    I too tried your above method to restore a new backup to an old device and got the same session could not be started error.

    I ended up loading up iPhone backup extractor and extractor the file I required manually and restoring my 3.1.3 that way.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •