I have my shsh blobs for 3.1.2 and the 3.1.2 firmware but I keep getting errors when I try to downgrade from 4.0? I have tried using the tts server on tinyumbrella as well as adding Surik's server to my hoasts file. The error I usually get is 28. I am running windows 7 64 bit an iTunes 9.2.